PC doesn't detect monitor on startup or after sleep mode

iDreaMzDK

Commendable
Feb 16, 2016
8
0
1,510
0
Hello!

I just recently bought a new monitor, Acer Predator XB271HUA.
The problem is that my PC sometimes doesn't detect the monitor. It is only sometimes, not everytime. Today when i turned on my pc, the monitor got the "No signal". After rebooting the pc, it works. I don't understand why it wont detect it everytime? Is it something to do with my GPU not giving signal sometimes? I used an old samsung monitor before without any problems.
BIOS is up to date, but i havent touched any settings, maybe that has something to do with it?
Also after pc sleep mode, sometimes it works and other times it dont? What is going on?

Monitor is connected to DisplayPort in GPU.
GPU: GTX 970 MSI
Motherboard: Asus-z97a

Thank you!
 
Jan 14, 2019
10
0
10
0
Make sure you are using a display port cable. Try another one. No adapters. Sounds like a bad cable/connector. After, change the frequency in the Nvidia Control Panel. If you don't have a Nvidia panel, update driver --did you get a disk? or use Device Manager.
 

iDreaMzDK

Commendable
Feb 16, 2016
8
0
1,510
0


It turns on but says "no signal". I tried removing the power cable and putting it back in, nothing happens, just no signal. I have to turn off the pc and turn it on Again and sometimes it Works but other times it doesnt.
 

iDreaMzDK

Commendable
Feb 16, 2016
8
0
1,510
0


I am using the display port cable that the monitor came with. I didnt get any disk. I changed the frequency to 144hz because thats why i bought the monitor. I also tried HDMI cable, but that didnt do the trick either.
 

iDreaMzDK

Commendable
Feb 16, 2016
8
0
1,510
0


There's only 1 monitor connected to the gpu via display port cable. I tried removing the cable and using my old samsung monitor with dvi cable and works instantly, no problems at all.
 

iDreaMzDK

Commendable
Feb 16, 2016
8
0
1,510
0


Hello! Yes i still need help, the last 3 times i turned on my pc the monitor worked but after sleep mode it still doesnt.
 

Similar threads