[SOLVED] PC doesn't POST after enabling Secure Boot mode in BIOS ?

saltySquash

Honorable
Nov 12, 2016
91
0
10,530
0
I wanted to play a game which requires you to enable secure boot mode and TPM 2.0 (Valorant).
So I enabled TPM and disabled CSM, but when I wanted to enabled Secure mode it required me to enroll a Platform key (PK) and I'm not sure if that has anything to do with it.
Anyway, I save the BIOS settings and try to boot but the screen just goes black, so I try to restart my PC, and then it didn't POST at all.

I noticed that the red LED panel on the motherboard lights up in VGA, which I knew means that there is a problem with the graphics card. I wasn't really sure how the GPU would be related to these bios settings at all, so I tried a CMOS reset. Well a few, as I kept trying a few times as it didn't work. Since the red VGA light persisted, I proceeded to try and reinstall the graphics card and check if cables and everything was sitting correct and it was.

I thought that if I at least could get into the BIOS somehow and revert the settings, it could fix it so I got the idea of trying to boot using only the integrated graphics in the CPU, but that didn't work either as the red VGA light was still red after uninstalling the graphics card and resetting the CMOS.

My next idea was to flash the motherboard, but I wasn't sure how to do so without access to the BIOS, so I downloaded the correct BIOS files to an USB flashdrive, and out of frustation I just tried putting it in and booting with it plugged in and let it sit for 5 minutes and went for coffee (I know that you usually have to pick it from the bios as the boot device).
To my suprise when I came back the red light in VGA was gone, but now the red light in BOOT was red. I powered off and took out the USB, tried to power on again, but the BOOT light persisted.

I thought it might have actually installed the BIOS update from the USB drive, and everything might even be working now, but it is probably trying to boot from the wrong drive (I have 4), so I disconnected all of them except the one with the OS on it.

It didn't work, and I'm stuck trying to figure out what to try next. (BOOT is still red, and it still doesn't POST)

SPECS:
Motherboard: Gigabyte AORUS PRO Z390
Graphics card: Zotac RTX 2080
CPU: Intel i7 9700k
RAM: Corsair Vengeance 3200 MHz


EDIT: SOLVED IT
 
Last edited:

FirstTimePc2020

Commendable
Feb 26, 2020
1
0
1,510
0
how did you solve it. I had secure boot before i updated my bios. After i updated to f10 secure boot was disabled and i couldnt enabled it without a black screen after
 

ASK THE COMMUNITY

TRENDING THREADS