Question PC doesn't POST

lucifer7303

Prominent
Jul 7, 2019
8
0
510
0
As the title says, my PC isn't POSTing

Previously I thought it was the Motherboard and PSU so got them replaced...got the mobo replaced twice actually..

So I tried turning it on outside the case with bare minimum parts..

Tried turning it on with just CPU, then CPU and RAM then CPU,RAM and GPU.....here are the videos for those tries:

View: https://imgur.com/a/qnDURzs


Still doesnt POST.

The PSU fans don't even spin when I turn it on
Could it be the CPU?

SPECS:

asus Prime a320m-k

Corsair 8 gb 3000Mhz

Zotac 1060 3gb

Ryzen 3 1st gen
PC used to work before....it just didn't POST one morning all of a sudden 5 months ago
 
I've already got the PSU and mobo replaced..order of replacement: mobo then PSU then again mobo
A broken CPU won't stop a system from turning on. You should see at least some sign of life on that system when you bridge the 2 pin. Can you make a video or a picture of that system from a top view where I can see all the cables connected and the cables connected to the PSU.
 

lucifer7303

Prominent
Jul 7, 2019
8
0
510
0
I
A broken CPU won't stop a system from turning on. You should see at least some sign of life on that system when you bridge the 2 pin. Can you make a video or a picture of that system from a top view where I can see all the cables connected and the cables connected to the PSU.
I've actually disassembled it now...but all the pins were securely connected to the mobo...so much so that it was difficult to take out the 24 pin one(connections that I made:24 pin,cpu to power supply,cpu fan to mobo and psu connection to GPU)....and there are no indications of life on my mobo ( no LED nothing)....there is an LED beside pcie x16 but that is audio related....although when my pc worked..that led used to turn on whenever I turned on my psu and it doesn't now ......so I checked the what the led is for...there is no mention of it in the manual and some people say on the net that it's audio related and is toggle-able in the bios
 

ASK THE COMMUNITY

TRENDING THREADS