• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question PC doesn't power on but motherboard lights up ?

Jul 1, 2021
4
0
10
0
I've had this problem for a couple months now but it got pretty bad this week. I started noticing that my computer wouldn't turn on in the morning even tho the motherboard lights were on, but almost Everytime, it would turn on after like 20 minutes.

But now if I try to turn it off at night, and try to turn it on in the morning, it won't turn on. It will randomly turn on after 12-20 Hours. I've tried replugging everything, resetting CMOS, replacing the CMOS battery with a new one, tried to turn it on with just 1 ram stick but nothing works.

I did try unplugging the power cable then unplugging the 24 pin, 8 pin CPU cable and the CMOS battery. Then plugged them back after 5 mins and it worked but only once.

Specs:
Ryzen 5 1600
Asus b350 motherboard
Gtx 950
8GBX2 2600Hz ram(don't know whcih company)
Enermax 500W PSU
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

How old is the PSU in your build? Can you try and source a donor PSU from a friend or neighbor who owns a reliably built PSU? The donor unit should have at least 550W of power for the entire system. If you can get into BIOS, take a look at your Sleep State settings. Speaking of settings, what is the model for the Enermax PSU? You stated the make and the wattage, not it's nmodel.
 
Jul 1, 2021
4
0
10
0
Welcome to the forums, newcomer!

How old is the PSU in your build? Can you try and source a donor PSU from a friend or neighbor who owns a reliably built PSU? The donor unit should have at least 550W of power for the entire system. If you can get into BIOS, take a look at your Sleep State settings. Speaking of settings, what is the model for the Enermax PSU? You stated the make and the wattage, not it's nmodel.
The PSU is 2 years old or maybe 1 and a half year old max. I don't really have someone that I can get a PSU from but I'll try to see if I can. If not I might just buy a new PSU cuz I have to get one sooner or later for my new build.

Regarding my PSU: it is the REVOLUTION D.F. 500W Watt 80 PLUS Gold Full-Modular Power Supply
 
I tried turning it on without the HDD and it worked but only once, I tried it again but it didn't work.
Can you give a more detailed description of what you see when it will not turn on? Are you getting no signal to the monitor or is Widows failing to load properly? Can you go directly into the BIOS if you hit the Delete button? Have you tried booting with no drives connected to see if it boots into the BIOS right away?
 

ASK THE COMMUNITY