[SOLVED] PC DVI-D to TV HDMI color issue

joezilla29

Reputable
Jan 7, 2016
17
0
4,520
1
I have a Nvidia GPU that's hooked up to my PC monitor (1920x1080) via a DVI-D cable. This GPU is also connected to my non-smart Philips TV by HDMI. There's a color/contrast issue and it looks as if the TV screen has this obnoxious blue filter over it with Win10 night light on. It is is especially noticeable when reading the text, which is REALLY blue and has also become very jagged. It did not used to be like this before I got the DVI-D cable. The colors and saturation used to match perfectly to what was on the PC monitor.

On my video card there's only one HDMI port that supports the cable I use, so if I wanted my PC to display on TV, I would have to disconnect the the HDMI cable connected to my monitor and plug it into the TV's; hence why I got the DVI-D cable. When I did this, I would have the same problem at times, but this was "fixed" by simply unplugging and re-plugging the HDMI either from the GPU or the TV. This is no longer a remedy.

Thus far I have tried:
  1. Different HDMI cables.
  2. Different HDMI TV ports and with different cables.
  3. Changing the RGB color format to YCbCbr422 and YCbCbr444 on Nvida control panel.
  4. Setting the RGB output dynamic range to 'full' from 'limited' on Nvidia control panel.
  5. Unplugging the DVI-D so that there's only the HDMI.
I would try a different TV, but I don't have another one. If anyone knows how to correct this or have come across a similiar issue, any help would be most appreciated.
 

joezilla29

Reputable
Jan 7, 2016
17
0
4,520
1
Oh my god, I feel like a fool. SO, I fixed it. I was not aware, or had forgotten, my TV setting had two different "modes". One called HDTV and the other called PC. I changed it from the former to the latter and everything looks great now, just as it once was. I don't know when or how it reverted, but I guess it doesn't matter anymore. Thanks Lutfij for helping me out!
 

Lutfij

Titan
Moderator
Could you pass on a link to the cable you're using? You might want to rule out a faulty DVI-D cable by sourcing/borrowing one from your friend or neighbor. You could also rule out corrupt drivers by using DDU for your GPU and uninstall your existing drivers. Reinstall the drivers using the latest found off of Nvidia's support site.

Speaking of GPU's, what are your system's specs?
List them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS: include version for W 10

Latest BIOS for your motherboard as well?
 

joezilla29

Reputable
Jan 7, 2016
17
0
4,520
1
AMD Ryzen 5 1600X
MSI X370 SLI Plus (MS-7A33)
Corsair 2x8 GB DDR4 SDRAM @ 1066.4MHz
Samsung SSD 850 Evo 500GB/Western Digital 2TB HDD
EVGA GTX 1070 PH-ES515E_AG PH
Thermaltake Toughpower Grand RGB 750W continuous power, gold certified
Phanteks PH-ES515E_AG PH Evolv ATX mid tower
Win10 Home (latest updates)

I did install the latest drivers for my GPU before posting, but I suppose it won't hurt to do so again after using DDU. Motherboard BIOS is by America Megatrends version 3.60 from 09/20/2017, however. And the 3ft 24+1 dual link male to male DVI-D cable is by UGREEN.

Edit: On second thought, the DDU seems pretty intimidating: "Requirement-Windows Vista SP2 up to Windows 10 May 2019 update 1903 (18362.xx) (anything higher is at your own risk)". I'm well past the recommended update.

Also realized all my motherboard drivers haven't been updated in almost 2 years, might as well give them a go.
 
Last edited:

joezilla29

Reputable
Jan 7, 2016
17
0
4,520
1
Oh my god, I feel like a fool. SO, I fixed it. I was not aware, or had forgotten, my TV setting had two different "modes". One called HDTV and the other called PC. I changed it from the former to the latter and everything looks great now, just as it once was. I don't know when or how it reverted, but I guess it doesn't matter anymore. Thanks Lutfij for helping me out!
 

ASK THE COMMUNITY

TRENDING THREADS