[SOLVED] PC extremely underperforming

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0
I recently built my first pc, and it has been running extremely slow on games which it should be able to run easily.

Such as Battlefield 1, I average around 40 fps in all low settings

PC Parts:
CPU: Ryzen 5 1600x
Motherboard: Asus B350
Memory: Corsair Vengeance 16GB
Storage: WD Blue 3 TB
Graphics Card: GTX 1070
Power Supply: Rosewill ARC-550
Operating System: Windows 10 Home 64 Bit

Any help would be appreciated
 

torveo

Commendable
Mar 8, 2017
20
1
1,515
0
Could be a lot of things causing this... In addition to what the guy above me asked, what are your temps while gaming? Maybe you didn't seat the CPU cooler properly and its thermal throttling? You may also want to check what clock speeds your 1070 is running at. A couple times now ive had an issue with mine where it would be stuck at 500mhz instead of its rated 1800mhz for whatever reason. Though a system restart always fixed that issue right up.
 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


I believe all my drivers are up to date, and I play on 1920x1080
 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


My CPU is around 45 Celsius and my GPU is around 950 MHZ.
 

torveo

Commendable
Mar 8, 2017
20
1
1,515
0
Hmmm, 950 is pretty low for a 1070... Do you happen to have any power saving features enabled in the Nvidia control panel?
 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


I changed the power management mode to prefer maximum performance from optimal power, it brought up to gpu to 1556 mhz.
 

Fros78

Reputable
Aug 24, 2015
77
0
4,640
2
That seems really low for a 1070, uninstall the GPU drivers with Display Driver Uninstaller and install them again, and keep the power management on optimal since it just forces the gpu at max load under idle or desktop usage
 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


Ok I changed the power management back, and I tried to uninstall and re download the drivers but nothing changed
 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


I used DDU before to remove the gpu drivers and I have 2 8gb sticks, they are running both at 2133
 

Fros78

Reputable
Aug 24, 2015
77
0
4,640
2

1st gen Ryzen loves high speed memory and 2133 is pretty low for DDR4
 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


I checked my memory should be running at around 3000 mhz is there any reasons that you know of that it could not?


 


You need to enable XMP in the BIOS
 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


I only see D.O.C.P and auto

 

0rB1Tz

Prominent
Jun 19, 2017
9
0
510
0


ok I will try it out, thanks
 

ASK THE COMMUNITY

TRENDING THREADS