Question PC Freezes Intermittently Takes Too Long To Boot

probuddha

Honorable
Mar 22, 2013
81
0
10,630
0
Hey guys

So this has been going on for a few months now. My PC would randomly start stuttering eventually leading to a full freeze. The only way out is to reset the PC. At that time, I have noticed that the system takes forever to get past the POST screen and the Starting Windows screen. All this while, the SSD LED flickers but slowly and mildly (the intensity of the light is low).

It eventually boots but takes 5-7 mins or longer. Once it boots, it runs fine till the cycle recurs.

Also when this happens, if I try to login on Safe Mode, it takes a very long time to boot into Safe Mode as well. So I guess that rules out any rogue drivers/programs causing the issue.

Interestingly, what I've found that when this happens, if I reconnect the SATA cable to my SSD, it starts working fine, even if not on the first attempt, after a couple of attempts for sure.

I have also tried switching the SATA Ports, changing the Sata cable but the problem persists. I've also looked into Event Viewer, but there's no log of any anomalies, except for the "Previous Shutdown was improper..." message.

Another important thing worth mentioning, is that when this happens, I often find one or two of my drives missing from the My Computer menu. It usually is the D: and the CD drive. It shows back up and vanishes randomly :-/

I am wondering what could be the cause for this problem. Could it be the PSU or the SSD or anything else?

My Rig

ASUS M5A78L-M/USB3
Crucial MX 100 250GB SSD
Corsair Vengeance 4GB x 2
Cooler Master V500 PSU
AMD FX 6100 CPU
Seagate HDD (500GB + 160GB)
Windows 7 PRO x64

Any help would be greatly appreciated.

Thanks
 

ASK THE COMMUNITY

TRENDING THREADS