Question PC Freezing while gaming

Oct 1, 2020
3
0
10
0
While this issue was occurring more so at the beginning of the year and I had not seen it in a while, the issue occurred again last night. I had a game up on my main monitor and my browser up on the 2nd monitor. Both my game and the browser froze, but I still had audio. Eventually, the audio went out as well and I could not interact with my PC.

I checked Event Viewer and it is the same error I was getting at the start of the year:

Error setting traits on Provider {8444a4fb-d8d3-4f38-84f8-89960a1ef12f}. Error: 0xC0000001

I did a search before posting this thread and while I saw solutions, I didn't see anyone 100% confirm that their issue was resolved. I ran cmd sfc /scannow, which did find and resolve some issues so perhaps this issue won't happen anymore.

One more thing to note, when gaming, I get some pretty nasty coil whine coming from PSU. I haven't thought much of it as I have read that some coil whine is normal and doesn't necessarily mean anything bad, but overtime it sounds like it has gotten louder. I did read in another thread that this issue could be related to a failing PSU. I'd usually be fine with buying a replacement, but PSU's are expensive at the moment. My question is should I wait to purchase a new PSU and see if the cmd sfc /scannow fixed the issue? While I did not run memtest86, the RAM I have is new. I'll post my specs below and can provide any additional information that might help resolve this issue.

CPU : AMD Ryzen 9 3900X 4.6GHz
GPU: NVidia GeForce GTX 1080 FE
RAM : Corsair LPX 32GB 3200MHz DDR4
Mobo : GIGABYTE X570 AORUS ELITE WIFI
SSD: Samsung 850 EVO 500GB, 860 EVO 1TB
PSU : Corsair CX750M
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS

Latest posts