Question PC Gaming issues.

Feb 18, 2019
33
1
35
0
Specs:
i7 4790 non-k (3.6ghz)
evga gtx 1070 superclocked
8gb ddr3 ram 1333mhz 1 is 1600mhz but since the other is 1333 is defaults both to 1333
2 hard drives - 1 - 500gb - 1 - 750gb


so i've been playing cs:go for around a year now, and i've upgraded my pc over the period of that 1 year well anyways i got a gtx 1070 a few months ago and a i7 4790 i had a sapphire r9 270x and a i5 4460 3.2ghz before and csgo ran fine around 150-200fps but good enough anyways when i upgraded i got around 200-300+ fps around 250fps constant and then these past week i've been getting 150fps if even that and it constantly drops to around 90 and even to like 60 that gives me a bit of lag and the 150fps isn't constant it drops and lags and you can feel the delay / input lag anyone know how i could fix this?
i have also tried my best to put everything into performance mode instead of quality from my bios settings to the windows power mode.

i have a feeling it might have something to do with the ram but it only goes up to like 75% - 80% while csgo is open and it's 50%-60% while idle i know that's high for idle so if anyone knows how to fix that also that would help a lot.
 
Last edited:

Vic 40

Titan
Herald
Don't use a tool like that to update drivers,just google your motherboard and get the drivers from the makers site for your motherboard. get the latest drivers for your gpu at Nvidia.Maybe even test some older drivers for the gpu.

For Intel could you try this as well,
Intel® Driver Update Utility

What if you use just one stick of ram? like the 1600mhz one. Test if you get more stable fps.Make sure you enable XMP in the bios to have it run at 1600mhz.
 
Feb 18, 2019
33
1
35
0
Don't use a tool like that to update drivers,just google your motherboard and get the drivers from the makers site for your motherboard. get the latest drivers for your gpu at Nvidia.Maybe even test some older drivers for the gpu.

For Intel could you try this as well,
Intel® Driver Update Utility

What if you use just one stick of ram? like the 1600mhz one. Test if you get more stable fps.Make sure you enable XMP in the bios to have it run at 1600mhz.
it could be the gpu drivers since i have updated it around 5 times or something like that because of new updates for my gpu so if this doesn't work i'll try the gpu drivers, also i had the ram sticks with my previous cpu / gpu, and it has worked normally before with these specs, but i will test it out if this doesn't work.
 
Feb 18, 2019
33
1
35
0
i've updated everything i know that needs to update clean installed my gpu now it's still at 150fps but now it's stable for now from what i can see also i have a feeling it might still be the ram but also now it could be the cpu fan because i downloaded a monitor and it goes into the orange 80% and sometimes jumps to red which is like 92% so i'll be buying a new cpu fan - hyper 212x and hopefully this will solve my problem, i'll keep you updated when i receive my cpu fan and if it's fixed if it's still not fixed i will try removing a ram stick, thanks for all the help.
 
Feb 18, 2019
33
1
35
0
Like Vic 40 said, you are better to use the DDU everytime when you upgrade to new GPU, or update the GPU driver.

what model? because not all the 600W 80+ are the same.
i used ddu when i got my new gpu and i also manually went through everything just to make sure after. also i'm not too sure on the model but i don't have any psu problems like the pc powering down randomly or anything like that so i don't feel like that is the problem.
 

Vic 40

Titan
Herald
Since installing the cpu cooler do check what psu and tell which one you have. With the psu maybe pushing atx specs odd things can happen although it maybe looking to work alright. High ripple might also cause issies.

Hope the new cooler will help. If so maybe a good time to clean the pc.;)

Looking at it's mainly csgo you worry about would i test with a single stick,just to see if it makes things more stable. That game doesn't use that much ram anyway afaik.
 
Feb 18, 2019
33
1
35
0
Since installing the cpu cooler do check what psu and tell which one you have. With the psu maybe pushing atx specs odd things can happen although it maybe looking to work alright. High ripple might also cause issies.

Hope the new cooler will help. If so maybe a good time to clean the pc.;)

Looking at it's mainly csgo you worry about would i test with a single stick,just to see if it makes things more stable. That game doesn't use that much ram anyway afaik.
Yeah, I'm buying the cooler on Monday, also I did clean my PC a few days ago. But if this doesn't work I will trywith 1 ram stick and get the model
 
Feb 18, 2019
33
1
35
0
so my cooler finally came in after like 2 weeks installed it today so the temperature is around 50% while gaming 30% idle or less and my fps seems to go up to 200fps sometimes but then drops to 100-150fps except this time it's constant fps no lag drops or anything. just the fps is still lower than i usually used to get.
 
Feb 18, 2019
33
1
35
0
i noticed while gaming in msi afterburner gpu temp is like 45% or below maybe 50% but when i touch my gpus chipset at the top it's very hot? is it supposed to be?
 

Vic 40

Titan
Herald
You talk about % when adressing temps,which i kind of odd. The degrees celcius is a better measurement.

You can look with the next to check temps of the gpu (and other parts as well as,also voltages),

download hwinfo64,
install and open it,
check "sensors-only",
click "run".
Make a partial picture of the gpu section (can use the windows "clipping tool"), post this picture here,

You can use Imgur to post a picture here,use the "img" link.
Click "new post" ->choose "upload images" -> "browse" ->choose the picture and click "open" ->put cursor on the picture that you uploaded->choose "share links" and copy the img link,paste it in your next post.
 

ASK THE COMMUNITY

TRENDING THREADS