PC got blue screen and is stuck on EFI screen, in need of help.

InfamousMango

Honorable
Oct 6, 2013
104
0
10,690
1
I built a PC a year ago and everything was working fine, until today, my PC crashed, i rebooted it and the blue screen popped up, i restarted it when i read the first 3 sentences since this is the first time that this has happened. It showed the msi bios screen and once it got after that there was a black screen and in the top right it said:

EFI Shell version 2.31 [4. 653]
Current running mode 1.1.2
map: Cannot find required map name.

Press ESC in 1 seconds to skip startup.nsh, any other key to continue.

the counter goes from 5 to 1 and then it just stops at 1 and does nothing, my keyboard and mouse don't function and i cant get into the bios, booting from a different hard drive and switching sata ports have no effects. My specifications are:
AMD FX 6300
Sapphire AMD R9 270X Dual-X
MSi 970-g43
Radeon entertainment memory (8 GB)
1 256 GB SSD
1 1TB HDD
500 watt modular corsair PSU
Microsoft Windows 7 UltimateN

I have tried switching drives and ports and no effect, can't get into bios since keyboard does not work anymore before boot (because of motherboard drivers). I am a little worried as to what I should do. I have seen other people have the same problem and they got it easily fixed, If anyone could figure out the problem I would love that.




 

InfamousMango

Honorable
Oct 6, 2013
104
0
10,690
1
Thanks for your reply to help, but I fixed it myself by leaving the cmos battery out of the motherboard for a few hours and that did the trick. What caused the problem was that when i installed msi fastboot for my pc, it was trying to make the gpu do something that it could not, if i had an msi card, then there would have been no issue.
 

ASK THE COMMUNITY

TRENDING THREADS