Question Pc hard crashing or getting DXI error on almost every game

Dec 9, 2018
12
0
10
0
I upgraded my GPU and PSU on 9th March and CPU on 14th March...Everything runs good no problems, no crashes.. It was running perfect for about 1 Month then i started to get "DXGI device remove" on almost every game...but if i downclock my gpu..theres no error..everything runs smoothly without crashes.Been playing like that until 2 days ago.2 days ago i used DDU to clean up GPU drivers bcs im tried to downclocking my GPU everytime im about to play games.So I clean up GPU drivers in Safe Mode and then install the latest driver and test a few games.

Kingdom Come Deliverance: Hard crash my pc if i didnt downclock my gpu...and after i downclock my gpu i can play for a little bit longer before giving me "Dxgi device removed" error and hard crashing my pc
Overwatch: Hard crashed my pc without downclocking GPU... didnt try OW with downclocking GPU
Final Fantasy XV: Crash but can still hear in game sounds and music and im able to force close with Task Manager
Monster Hunter World: Crashed
GTAV: Crashed without error
PUBG: Crashed with DXGI error
Destiny 2: Crashed with DXGI error

Basically these hard crashes happened after I clean up gpu drivers using DDU.I've used DDU before idk why this happened.Usually i can fix the DXGI error just by downclocking my gpu.

PC Specs
OS: Windows 10 ultimate - 64-bit
CPU:AMD Ryzen 7 2700X
Cooler: Ryzen Wraith Cooler (Stock Cooler)
GPU: MSI RTX 2070 GAMING Z 8G
RAM:2x G.Skill Trident Z (RGB) 8GB 2400ghz =16GB
Case:Armaggeddon Infineon 5000
Motherboard: Asus ROG STRIX B350-F GAMING
PSU: Corsair VS 650w
I forgot my HDD specs but its Seagate Barracuda

Things i tried:
Reformat pc with fresh Win 10
Clean GPU drivers with DDU
Use the TdrLevel method to try and stop crashes
Stress test and no crashes while testing
Cpu usage 100% on heavy load ,Temps: 66°c
Gpu Max GPU Temp: 65°C ,Usage/Load 95%
Gpu temps while gaming is 60+ to 70+ °C
Tried turning on and off D.O.C.P but games still crashing


I havent test my ram and HDD yet...

Is it something wrong with PSU or something else?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS