Question PC having either VGA or Memory booting issues. I'm out of ideas. Long detailed explanation of my problem

May 8, 2022
4
0
10
0
Here's my RIG:

  • Intel Core i9 9900k
  • Nvidia 2080 Super FE
  • 32gb Trident Z RGB RAM CL16 16-16-16-32
  • Asus ROG Z390 Maximus XI Formula
  • 2 1tb Samsung 970 EVO Plus NVMe M.2 SSD
  • Corsair RM850 Gold certified
I have had this rig built since September 2019 with absolutely no issues at all until about a month or so ago.

About 1 month ago I went to turn on my PC and a few seconds later it turned off and then started back up. It was weird to me, but it started and had no issues. This started happening more frequently, but it didn't happen every start up. As of a week ago my PC started going through not only 1, but 2 boot cycles before turning on. Now it happens every time I go to start my PC. Still once it gets started I have no issues with it at all. I decided it was time to start self diagnosing the problem.

As I went to turn on my PC I started paying attention to the Q-code to identify the issue. At first I would get a yellow light pop up with the code 34 and it would immediately turn off once the yellow light came on. Yellow is a ram issue, so I first decided to clear my CMOS and see If that would solve the issue. I cleared my CMOS, went into the bios and turned back on XMPII. Still I had the issue. I proceeded to try this 2 more times but once with leaving my RAM at default setting and the other switching it to XMPI. No luck on either these options. I then decided to go down to 1 stick of RAM and see if maybe one of my sticks became defect. Still, the issue was not resolved.

Throughout all of these attempts I kept paying attention to my Q-code to see what messages were displaying. I noticed that it wasn't always failing on a yellow light. Sometimes I would get a white light before it would reboot. White light is a VGA issue so I thought maybe It's my GPU but I don't have a spare GPU laying around to test a different GPU, but I proceeded to try a few more things. First I updated my bios to the latest firmware by doing a bios flashback. I haven't needed to update my bios since I got my PC because I've had no issues with it so I thought maybe an update would fix it. I successfully updated my bios but the double reboot kept accruing. I kept looking online for solutions and tried a few more tests. I tried unplugging all cables that aren't needed to boot because I read that could cause a VGA issue. I tried a different DisplayPort cable to my monitor because I read that a faulty DisplayPort cable could cause issue. I took out my CPU cooler and reseated my CPU while also changing the thermal paste because I read that it could be a CPU issue. I have had zero luck with any of these options and my computer still goes through 2 boot cycles before turning on.

Now there are a few more details to share that I have discovered. Whenever I clear my CMOS a reboot my PC, a few more things occur, that don't occur any other time. After a CMOS clear, my computer goes through 3 boot cycles before resting on a white light with code 78. It will sit like this for about 2-3 minutes before reading code 34 getting to a green light and then once again rebooting. When it reboots my computer lands on a white light again and the OLED screen reads 'identifying HDD'. It will sit like this for another 2-3 minutes and finally boot up. This scenario ONLY happens after I clear my CMOS. Once it happens and I test a reboot, it just goes back to doing 2 boot cycles before booting up.

I am completely at a loss here. I don't know what could be causing this. I don't ever o into my bios to change stuff around anymore because my computer has worked as intended up until now. I haven't done any driver updates in months and I don't touch or move my PC at all. It sits in the corner of my room on a hardwood floor, and its sat there for 2 years now with no issues. I typically try to clean it out every 6 months or so and have had no issues with it until about a month ago. It might be worth to note that Asus Armory Crate does not, and has not every worked for me despite being on an Asus board. The app itself works and I can change my RGB lighting but the Tools section to check for bios updates or driver updates does not load for me. I have to manually go to the Asus website to find and download drivers. I have tried to uninstall and reinstall armory crate but have had no luck getting the tools section to ever load for me. I mention this as some what of an issues I have had, but I doubt this has anything to do with my issue I'm currently having because It's cause no issues previously with my PC. Another reason I am so lost is because once my PC finally boots up and I get into windows and start gaming, I have no issues with it at all. It hasn't blue screened on me. I haven't had games crash or get low FPS. My system still reads that all 4 of my RAM sticks are connected and working with the correct speeds and cas latency. I just don't have a clue what's going on. Maybe my motherboard is dying on me, but I'm not sure what else to test. I don't have a second GPU and I don't have extra RAM laying around to check. This is my first PC build and I did build it myself.

A few more things to note:
  • Code 78 in the asus manual is ACPI Module initialization
  • Code 34 is not listed but the manual says code 32-36 CPU post-memory initialization, so I am assuming code 32-36 means any code number between those, which would include code 34
  • Sometimes code 7F or 02 will pop up. 7F is Reserved for future AMI DXE codes. 02 is AP initialization before microcode loading
Not sure if these last codes mean anything. I try to pay attention to codes I see a lot and I see those more often than a few others, but I also assume that these always pop up as part of the PC start up process but I am not sure.

Anyhow thanks for the long read. Hopefully someone much smarter can maybe identify what's going on here
 

ASK THE COMMUNITY

TRENDING THREADS