Question Pc in a reboot loop after RAM change

Jun 3, 2020
2
0
10
0
Hello all.
I have an ASUS P7H55D-M EVO MB with an INTEL CORE I5-650 3.20 installed and the RAM I've been using is the following : CORSAIR XMS3 DHX DDR3 4GB (2X2GB) PC3-10666 (1333MHZ) CL9 DUAL CHANNEL KIT . I decided recently to upgrade RAM and bought the following: CORSAIR CMX8GX3M2A1333C9 XMS3 8GB (2X4GB) PC3-10600 DUAL CHANNEL .
I tried adding the new sticks to the existing ones but got a reboot loop right after the BIOS screen. I then tried removing all sticks and using only the new ones but no matter the channel I selected (Blue or Black) I got the same. I then tried using only one of the new sticks but still the same. As soon as I put any of the original sticks the pc boots normally.
I tried clearing cmos but still the same. Tried using the onboard graphics instead of the pci I had installed, still the same.
The only thing I can think that I haven't tried to do yet is to press the MemOk button which I will try later tonight.
Any ideas on what else to try?

PS. According to the MB's manual the Corsair module that is supported is the CMX8GX3M4A1333C9 XMS3 (4x2) instead of (2x4) but I think that's because the supported modules pdf is old and this module was not out by the time it was created.
Voltage, timings etc are all the same and it should be supported.
 
Jun 3, 2020
2
0
10
0
Update.
I tried the MemOk button but no gain.
I tried some other DD3 RAM I had (RAM HYPERX HX318C10FWK2/8 8GB (2X4GB) DDR3 1866MHZ) which I have on another PC still not working, although I did not have any real hope with that since the freq was well out of the supported).
I then tried those 2 Corsair RAM sticks on the PC where I have the HyperX RAM installed and it worked just fine. I am actually working on this pc now with 16GB of RAM.
So the sticks are just fine.
Any ideas why they don't work on the other one?
 

ASK THE COMMUNITY