Question PC Instantly powers off when playing certain games

May 27, 2022
4
2
15
0
This system was built a few months ago in February and no matter how hard I try the problem won't go away.

I've gotten a replacement PSU from EVGA and the problem continues. I've done 3 passes on Memtest with 0 errors and tested my temperatures with HwMonitor and it hardly ever reaches 80c under heavy load. Event viewer says the crash is a kernel 41 power error.

I can play Dying Light 2 just fine, while Dragon age: Origins and the new Lego Star Wars game cause the crash to happen, it doesn't appear to matter how modern or demanding the game is. It seems to happen randomly somewhere between 5 minutes to an hour after I start playing.

My Build:
GPU - EVGA RTX 3070 Ti FTW3 Ultra
CPU - Ryzen 5 5600g
PSU - EVGA Supernova 750 P5 80 (750 Watts)
Mb - Asrock b550m Steel Legend
Ram - T-Force Delta 16GB DDR4 3200

Thanks so much for any help!
 
Last edited:
This system was built a few months ago in February and no matter how hard I try the problem won't go away.

I've gotten a replacement PSU from EVGA and the problem continues. I've done 3 passes on Memtest with 0 errors and tested my temperatures with HwMonitor and it hardly ever reaches 80c under heavy load. Event viewer says the crash is a kernel 41 power error.

I can play Dying Light 2 just fine, while Dragon age: Origins and the new Lego Star Wars game cause the crash to happen, it doesn't appear to matter how modern or demanding the game is. It seems to happen randomly somewhere between 5 minutes to an hour after I start playing.

My Build:
GPU - EVGA RTX 3070 Ti FTW3 Ultra
CPU - Ryzen 5 5600g
PSU - EVGA Supernova 750 P5 80 (750 Watts)
Mb - Gigabyte b550m Steel Legend
Ram - T-Force Delta 16GB DDR4 3200

Thanks so much for any help!
Proper bios and mobo drivers?
Take side panel off the case and test.
 
This system was built a few months ago in February and no matter how hard I try the problem won't go away.

I've gotten a replacement PSU from EVGA and the problem continues. I've done 3 passes on Memtest with 0 errors and tested my temperatures with HwMonitor and it hardly ever reaches 80c under heavy load. Event viewer says the crash is a kernel 41 power error.

I can play Dying Light 2 just fine, while Dragon age: Origins and the new Lego Star Wars game cause the crash to happen, it doesn't appear to matter how modern or demanding the game is. It seems to happen randomly somewhere between 5 minutes to an hour after I start playing.

My Build:
GPU - EVGA RTX 3070 Ti FTW3 Ultra
CPU - Ryzen 5 5600g
PSU - EVGA Supernova 750 P5 80 (750 Watts)
Mb - Gigabyte b550m Steel Legend
Ram - T-Force Delta 16GB DDR4 3200

Thanks so much for any help!
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 12 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • restart the pc to bios, disable AMD fTPM and Secure Boot, save and exit, go to bios again, then update to this bios, and after updating the bios, go to bios again and then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled, and prolly wont available on your motherboard settings maybe?), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot.

  • Install latest nvidia driver ,and the latest radeon driver or try Amernine Zone Driver for amd if you need it, and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 
May 27, 2022
4
2
15
0
Thanks for the advice, I went through all the steps except for the last one and it still happens. I'm working on getting another PCIE cable since right now I'm using a branching one.
 
Reactions: Koekieezz
May 27, 2022
4
2
15
0
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 12 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • restart the pc to bios, disable AMD fTPM and Secure Boot, save and exit, go to bios again, then update to this bios, and after updating the bios, go to bios again and then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled, and prolly wont available on your motherboard settings maybe?), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot.

  • Install latest nvidia driver ,and the latest radeon driver or try Amernine Zone Driver for amd if you need it, and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
Finally finished doing all of this and I'm still getting the crashes.
 

ASK THE COMMUNITY