• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Pc is on but monitor wont even turn on and gpu fans stop spinning 5s later

Apr 13, 2020
4
0
10
0
So i've tried to switch out my gpu with an asus rog 1050 2gb, and what happened is on pc startup the gpu led flashes white (as it should) for a second, then starts flashing red, and the gpu fans stop spinning a few seconds later. After that the pc would restart and then do it again and again. On startup the monitor doesn't even power on, doesn't display anything at all and now even if i try to use the old graphics card i get the same results. The only thing that comes to mind is that i've probably short circuited my motherboard or my PSU when i was messing around with my cpu. Can anyone tell me if theese are sympthoms of a motherboard short circuit or more of a PSU malfunction and what would be advised for me to do next? (i'm on a very strict budget and i can't really waste my money on replacing both or buying tools to diagnose the issue myself)
 
Apr 13, 2020
4
0
10
0
What is the full system specs of the system?
when i inserted the new gpu the specs were: msi b85m-e33 motherboard, Asus rog gtx 1050 2gb, i5 4670 with a stock cooler, 8gb ram and the only thing im not sure about is my psu but im sure its 500w or higher
 
Apr 13, 2020
4
0
10
0
When i start my pc my cpu fan spins normally but gpu fans stop spinning in a few seconds (rog gtx 1050 2gb led turns red), also my monitor doesn't seem to react and like 10 seconds later my pc restarts. If i change my gpu to my previous one or try the igd i still get similar results with my pc restarting a few seconds later and monitor not even powering on. I kind of didn't know what to do so i've switched out my hard drive with an old one with no change, switched out ram with no results, tried different gpu's and narrowed it down to it being my motherboard or PSU. Can someone tell me what am i having an issue with? Is it my PSU or my Motherboard?

My specs are :
600 w PSU
mobo: b85m-e33
i5 4670 processor with a stock cooler
gpu: rog gtx 1050 2gb
8 gb ram
random 1 tb harddrive
 
Apr 13, 2020
4
0
10
0
did you fix the bend pin?
somewhat did as best as i could.. i dont know if i can do any better than that. I am actually prepared to buy a new motherboard or a psu i just dont have enough money to buy both so i really want to find out which one i should replace
 
Apr 13, 2020
2
0
10
0
Spec
I9 9900KF
Gigabyte Designare

I was having the same issues since last night, I’ve tried different psu, switch MB, memory, HD, cpu and gpu, still nothing. I hit the power button fans starts for a few seconds then stop. Finally I pulled all the memory out start with one from slot A , nothing then slapped in a 2nd one then there was life. Computer boots and suggest I insert the memory into A2 and B2 so I did and then it goes dark with same issues. So I think you might want to start reseating you RAM.
 

ASK THE COMMUNITY

TRENDING THREADS