Question PC is ON but won't boot ?

Sep 24, 2021
4
0
10
0
Hi, folks, I have an issue with my PC.
Suddenly a few days back, my PC won't boot but it is ON (lights, fan, etc, are on). Then I decided to clean all the stuff inside, did guessing that it caused by dust. After it done, I did assembly all the parts and turn it on, and it did boot, so I decided to changed the setting of the priority boot hard drive in the BIOS. Then, it worked normally.

And the next day, I turned on my PC but it happened again, it won't booting but the PC is on. I guess it has the problem with the hard drive, but it did not I think. I did unplug and plugged in my hard drive, but it happened all the time.
My PC wont entering boot after it turned off.

I did some troubleshooting, but signed no good solution :
  • Check the CPU if it any bent pins, and it's not. CPU is normal.
  • Reinstall the RAM and GPU
  • Clear CMOS
  • Updating the BIOS
  • Using only my SSD to boot
Any suggestions?
Thank you.

Specs:
MSI X370 Gaming Plus
Ryzen 7 1700x
GSkill RipjawsV F4-C3200-C16D 16GB
AMD Sapphire Nitro RX480 8GB
PSU FSP HyperM 600W
Samsung Pro 850 256Gb SATAIII (OS)
SATAIII: HDD Seagate Firecuda 2TB, SSD Toshiba Q300 250GB
M.2: Lexar NM610 500GB
 
Hi, folks, I have an issue with my PC.
Suddenly a few days back, my PC won't boot but it is ON (lights, fan, etc, are on). Then I decided to clean all the stuff inside, did guessing that it caused by dust. After it done, I did assembly all the parts and turn it on, and it did boot, so I decided to changed the setting of the priority boot hard drive in the BIOS. Then, it worked normally.

And the next day, I turned on my PC but it happened again, it won't booting but the PC is on. I guess it has the problem with the hard drive, but it did not I think. I did unplug and plugged in my hard drive, but it happened all the time.
My PC wont entering boot after it turned off.

I did some troubleshooting, but signed no good solution :
  • Check the CPU if it any bent pins, and it's not. CPU is normal.
  • Reinstall the RAM and GPU
  • Clear CMOS
  • Updating the BIOS
  • Using only my SSD to boot
Any suggestions?
Thank you.

Specs:
MSI X370 Gaming Plus
Ryzen 7 1700x
GSkill RipjawsV F4-C3200-C16D 16GB
AMD Sapphire Nitro RX480 8GB
PSU FSP HyperM 600W
Samsung Pro 850 256Gb SATAIII (OS)
SATAIII: HDD Seagate Firecuda 2TB, SSD Toshiba Q300 250GB
M.2: Lexar NM610 500GB
When you say "Not booting", does that mean no picture of BIOS or no Windows ?
 

ASK THE COMMUNITY