Question PC issues with multiple (3) Wireless mice.

ctell88

Distinguished
Sep 17, 2010
11
0
18,510
0
I am having issues with wireless mouses randomly lagging/disconnecting/skipping while in use on my Windows 10pc. I have already used 3 different wireless mice on my PC. Razer Basilisk ultimate, Razer Basilisk hyperspeedX, Logitech G305 and they all have the same issue. I will soon try a brand new Basilisk ultimate and update if people are responding. They are not plugged in at the same time. I have already tried updating the drivers through device manager(always tells me it is up to date) and have downloaded and installed the firmware updates on all the mice. I have also tried multiple usb ports and its always the same issue.
I also have a wireless keyboard. The problem seems to have started when I started using the keyboard, but i have not had any issues with it's connectivity.

Could this be a motherboard issue? I'm not really sure what else I could do to make a wireless mouse work.
 

Wolfshadw

Titan
Moderator
I had a similar issue with a couple wireless mice as well. Only real difference is that I've been using a wireless keyboard all along. Thought it might have been the mouse battery, but that didn't change anything. Ended up returning to a wired USB mouse. Still using the wireless keyboard without issue.

-Wolf sends
 

ctell88

Distinguished
Sep 17, 2010
11
0
18,510
0
oof. Im really hoping i dont need to return to wired. Always snagged the wire on my monitors V-shaped legs, lol. Its the reason I switched over in the first place.
Anywways, thanks for responding and getting me ready for no seeable solutions. 🖖
 

Wolfshadw

Titan
Moderator
What version of Windows are you running? I'm running 20H2. Since it happened to two separate mice with me, I'd leaning towards some Windows update or a hardware failure of some type with my USB dongle.

-Wolf sends
 
if mice with a proprietary USB wireless dongle aren't working as expected,
try a Bluetooth version.

had a similar issue with a Logitech mouse & keyboard USB wireless set I got to use with our media center system.
mouse always had noticeable lag.
keyboard always worked fine.
switched out the mouse for a cheap Bluetooth alternative and it has been working perfectly.
 

ASK THE COMMUNITY