Question PC just turns itself off on startup sometimes

Rostropovich

Honorable
Oct 14, 2014
40
0
10,530
0
Hi guys!

I'm not sure where to post this question but it might be PSU related so here it is.
I had this build from my signature for seven months now and it's wonderful, fast and the performance is incredible but I have an issue now and again.

Sometimes when I turn on my PC it just turns itself off on the Windows loading screen. I thought maybe first it's the NZXT CAM software because I've read it creates problems but I've uninstalled it and it still happens. When it does happen all the LED lights of the case get reset to factory default white light. I've been trying to figure out what is happening but am honestly at a wits' end.

Does anyone know how to proceed and solve this thing?
 

Rostropovich

Honorable
Oct 14, 2014
40
0
10,530
0
Can you test this PC with different PSU ?
Sadly, I can't. It's the only one I have currently. Maybe it's worth mentioning that the PC makes a click sound when it's being turned on and off. I found that charming but when I think about it now I'm not sure if it's even supposed to happen.
 

Juular

Prominent
Mar 14, 2020
581
124
590
21
Maybe it's worth mentioning that the PC makes a click sound when it's being turned on and off.
That's irrelevant, it's just a relay shutting off NTC thermistor at startup to cool it off. On your issue, i'm really not sure but this PSU lineup had problems with ASUS Strix GTX970 GPU maybe it's the case with RTX2070 too but regardless since your system shuts down completely it indeed looks like either PSU problem or compatibility issue of some sort between the PSU and other hardware. Contact Seasonic support.
 

Rostropovich

Honorable
Oct 14, 2014
40
0
10,530
0
Okay, sorry for resurrecting the thread but there's an update.

After updating the mobo BIOS the LED's don't reset anymore when the described issue occurs. Now, though, it feels like the power button doesn't always turn on the PC when it's pressed.

Half an hour ago I've been pressing it multiple times and it turned itself off twice on me which never happened before. It felt like I had to press the button really hard to turn the computer on.

I'm really at a loss here. Any ideas what the reason for this weird issue could be?
 

ASK THE COMMUNITY

TRENDING THREADS