[SOLVED] PC keep shutting down

Nov 28, 2020
4
0
10
0
Hello guys,

I just keep getting issues to boot my newly build pc. I Q-flashed my mobo with the latest BIOS, and I still get my pc shut down after 20 sec.

Here is my spec
CPU: 5900x
MOBO: B550 aorus elite AX V2
RAM: G. Skill Trident Z RBG 3600 CL 17
PSU: EVGA 850 GA gold
Drive: SN750 1tb
GPU: i'm testing with my old GPU R9-270

Any idea how to solve this?
(I heard people say I need a CPU cooler), I did order one and it will arrive in approx 2 days

Thanks in advance
 
Last edited:

allidsarebusy

Reputable
Sep 7, 2016
61
22
4,545
1
Let me get this straight..... You don't have a CPU cooler right now?

P.S.

If it still boots it's a good news. Don't do anything with it and wait for your cooler. Don't forget the cooling paste while installing it.
 
Reactions: kurdtnz

allidsarebusy

Reputable
Sep 7, 2016
61
22
4,545
1
Let me get this straight..... You don't have a CPU cooler right now?

P.S.

If it still boots it's a good news. Don't do anything with it and wait for your cooler. Don't forget the cooling paste while installing it.
 
Reactions: kurdtnz
Nov 28, 2020
4
0
10
0
Let me get this straight..... You don't have a CPU cooler right now?

P.S.

If it still boots it's a good news. Don't do anything with it and wait for your cooler. Don't forget the cooling paste while installing it.
my CPU cooler is on its way to my house, and i will just leave everything as it is for now.

What cooler have you ordered? Can only repeat what allidsarebusy has said, do not switch it on again until you have a cooler!
I ordered the H150i Elite Capellix
 

ASK THE COMMUNITY

TRENDING THREADS