Question PC keeps Freezing after short use

Rowannnx

Honorable
Apr 24, 2014
5
0
10,510
0
I just built a new computer however it keeps freezing.
The freezes all happen within 10 mins of use.
I usually always boot up windows but will freeze shortly after that.
I have no idea why.

MPG 2390 Gaming pro carbon motherboard
Intel Core i7-9700k cpu
Cool Master Thunder 600W PSU
Kingston Hyper X Fury DDR4 RAM

I have changed PSU's - Still freezes
Changed SSD's (with other versions of Windows) - Still freezes
I have changed RAM - Still freezes
I have taken out the GPU - Still freezes
I have reset CMOS - Still freezes

Things to note:
The motherboard I have obtained has a 12 pin connector?
I have only connected 8 to my PSU - I have researched this and gathered the extra 4 pin is for overclocking.
This could be an issue but I doubt it.


I am considering the possible problems being either my Motherboard or my CPU.
Is there anything else I am overlooking?

Thanks in advance for your assistance.
 

vov4ik_il

Prominent
Mar 23, 2020
800
94
490
9
Things to note:
The motherboard I have obtained has a 12 pin connector?
I have only connected 8 to my PSU - I have researched this and gathered the extra 4 pin is for overclocking.
This could be an issue but I doubt it.
When you try something out of spec (like not connecting some of the power pins) you are running experimental and apparently not very successful.
 

Nemesia

Respectable
Nov 6, 2019
2,422
465
1,890
91
Did you do a clean install of Windows 10 when you built the new system or did you use another drive with Windows already installed?

Are you using the latest BIOS for that board?

Did you install the motherboard chipset drivers?

What are your RAM? Are they from a kit?
 
Reactions: Rowannnx

Rowannnx

Honorable
Apr 24, 2014
5
0
10,510
0
Did you do a clean install of Windows 10 when you built the new system or did you use another drive with Windows already installed?

Are you using the latest BIOS for that board?

Did you install the motherboard chipset drivers?

What are your RAM? Are they from a kit?

I have installed all the drivers that came with Board CD on the OS

Thank you for the BIOS tip - I will double check and install the latest version now.

My RAM has been interchanged a few times and I have checked on multiple PC's so I dont think this is the problem.
However it is from a KIT
Kingston HyperXFury 16GB DDR4 3200RAM

As for the clean install - I could not install windows 10 on my computer because it kept freezing. I instead performed a clean install on the SSD I am using with components from another PC.

I have tried using another confirmed working SSD with windows on this computer yet it Still Freezes. So I Do not think the SSD is the problem either
 

ASK THE COMMUNITY

TRENDING THREADS