Question PC keeps losing connection to to the internet, using ethernet.

Aug 20, 2020
17
0
10
0
Router - BT Smart Hub 2
Motherboard - ASrock Extreame4 z370

The internet will only drop on my PC, google etc will still load on my phone, it usually disconnects for like a minute or so then reconnects but sometimes i have to pull the ethernet cord out and plug it back in. The problem only just started to show up, been using the same ethernet cable for about a year now, anyone know of any issues that may be causing this?
 

Ralston18

Titan
Moderator
What Ethernet connection are you using on your PC: Built in LAN port, Ethernet PCIe card, or perhaps a USB to Ethernet Adapter?

Check the applicable LAN port for signs of damage or debris inside. Use a bright flashlight. Ethernet cable plug should fully and firmly clip into the LAN port.

Try another known working Ethernet cable.

Make and model information for the Ethernet adapter(s) being used? Ensure that only one Ethernet adapter is enabled.

Manually download the applicable Ethernet adapter drivers via the manufacturer's website. Reinstall and reconfigure.
 
Aug 20, 2020
17
0
10
0
What Ethernet connection are you using on your PC: Built in LAN port, Ethernet PCIe card, or perhaps a USB to Ethernet Adapter?

Check the applicable LAN port for signs of damage or debris inside. Use a bright flashlight. Ethernet cable plug should fully and firmly clip into the LAN port.

Try another known working Ethernet cable.

Make and model information for the Ethernet adapter(s) being used? Ensure that only one Ethernet adapter is enabled.

Manually download the applicable Ethernet adapter drivers via the manufacturer's website. Reinstall and reconfigure.
the ethernet cable goes from my pc directly to the router, got no clue what the make of my ethernet cable is so i cant really download the drivers for it.
 

ASK THE COMMUNITY