Question PC keeps powering on and off ?

Sep 2, 2021
6
1
15
0
I bought parts for a brand new pc from Newegg and assembled it. But when I built it; it kept powering off and on in a cycle. The components are:
  1. AMD Ryzen 5 5600x (CPU)
  2. MSI B550M PRO-VDH WIFI Micro ATX AM4 (Motherboard)
  3. Corsair Vengeance LPX 16 GB (2x8) DDR4-3200 CL16 Memory (RAM)
  4. EVGA SuperNOVA GA 750 W 80+ Gold (PSU)
  5. MSI GeForce GTX 1050 Ti 4GB (GPU)
  6. NZXT H510 Mid Tower (Case)
  7. Western Digital Caviar Blue 1TB (Disk)
I have removed the components and rebuilt the pc and the result is the same. I have updated the BIOS for the motherboard with a USB and it still cycles between powering off and on. I have also checked the pins in the motherboard and I haven't seen any bent pins in them. Can anyone help me in troubleshooting?
 
Sep 2, 2021
6
1
15
0
Try reseating your ram. A lot of boot loop issues are usually a result of faulty or incorrectly seated ram. Try with 1 stick, try with the other.
It still keeps cycling between on and off. I have put each stick in each slot and it still powers on and off even with no ram.
 

EyyMunchian

Reputable
Dec 28, 2016
224
19
4,715
16
Try removing some of the non essential cables from the power supply. Run it on bare minimum. Without the GPU even. just have the motherboard and cpu connector. I think since your psu is modular one of the cables could be screwing up the system. My buddy used a corsair cable for a corsair PSU but of a different model, everything fit well but it would cause a boot loop. This could be the issue.
 
Sep 2, 2021
6
1
15
0
Try removing some of the non essential cables from the power supply. Run it on bare minimum. Without the GPU even. just have the motherboard and cpu connector. I think since your psu is modular one of the cables could be screwing up the system. My buddy used a corsair cable for a corsair PSU but of a different model, everything fit well but it would cause a boot loop. This could be the issue.
I removed everything except the CPU, cable for power to CPU, cable for power to the motherboard cable Front Panel, and CPU fan. But the pc keeps powering on and off.
 
Sep 2, 2021
6
1
15
0
I bought parts for a brand new pc from Newegg and assembled it. But when I built it; it kept powering off and on in a cycle. The components are:
  1. AMD Ryzen 5 5600x (CPU)
  2. MSI B550M PRO-VDH WIFI Micro ATX AM4 (Motherboard)
  3. Corsair Vengeance LPX 16 GB (2x8) DDR4-3200 CL16 Memory (RAM)
  4. EVGA SuperNOVA GA 750 W 80+ Gold (PSU)
  5. MSI GeForce GTX 1050 Ti 4GB (GPU)
  6. NZXT H510 Mid Tower (Case)
  7. Western Digital Caviar Blue 1TB (Disk)
I have removed the components and rebuilt the pc and the result is the same. I have updated the BIOS for the motherboard with a USB and it still cycles between powering off and on. I have also checked the pins in the motherboard and I haven't seen any bent pins in them. Can anyone help me in troubleshooting?
So I figured out what was wrong with my build. In the case, came an adapter for the front panel and I didn't use it. The front panel without the adapter is for Intel motherboards only; the adapter is for AMD motherboards. If you don't use it on an AMD motherboard then it will power cycle.
Hope this helps someone!
 

ASK THE COMMUNITY

TRENDING THREADS