Question PC keeps restarting but without any errors ?

Joel jr

Prominent
Jan 21, 2021
16
0
510
0
Specs:
Ryzen 5 5600x
Asus B550 F gaming
RTX 3070
16gb ram (planning to upgrade 32gb)
seasonic 850w
M.2 500
HDD 2TB

My Pc keeps restarting without any errors every time i open 2 games which is dota 2 and mir4 and another multiple tab of browsers, do you guys think my cpu can't handle all the work? i tried to monitor it using msi afterburner and my cpu temp reach 70+ and usage of 100%. Is it worth it to upgrade my cpu to ryzen 9 5900x? or is there any cause of this problem?
 

keith12

Illustrious
Specs:
Ryzen 5 5600x
Asus B550 F gaming
RTX 3070
16gb ram (planning to upgrade 32gb)
seasonic 850w
M.2 500
HDD 2TB

My Pc keeps restarting without any errors every time i open 2 games which is dota 2 and mir4 and another multiple tab of browsers, do you guys think my cpu can't handle all the work? i tried to monitor it using msi afterburner and my cpu temp reach 70+ and usage of 100%. Is it worth it to upgrade my cpu to ryzen 9 5900x? or is there any cause of this problem?
Hey there,

It could be your PSU. Which exact model is it? You might also try update your bios to the latest version to rule that out as an issue. Your CPU is a good match with your GPU you don't need a bigger faster CPU. The 5600x is a stellar gamer.
 
Reactions: kurdtnz

Joel jr

Prominent
Jan 21, 2021
16
0
510
0
Hey there,

It could be your PSU. Which exact model is it? You might also try update your bios to the latest version to rule that out as an issue. Your CPU is a good match with your GPU you don't need a bigger faster CPU. The 5600x is a stellar gamer.
i have seasonic focus plus gold gx 850w and my bios is latest already.
 

Joel jr

Prominent
Jan 21, 2021
16
0
510
0
Hmmm, that PSU is a rather good one! How old is it?
almost 1yr sir, any idea what part of my components have a problem? and additionally the problem is more noticeable when im playing DOTA 2 which is on max settings. Temps are fine about 60-70c
 

Joel jr

Prominent
Jan 21, 2021
16
0
510
0
I'd suggest updating all your drivers, but specifically the chipset driver. Let me know how that goes.
Sorry for late reply, looks like i've found the culprit which is the armoury crate app of asus after i uninstalled it the problem is gone.
 

ASK THE COMMUNITY

TRENDING THREADS