Question PC keeps starting and stopping

Feb 6, 2022
2
0
10
Hello,

I’ve recently rebuilt my PC and the only component that I renewed was my motherboard. After I built it, it’s been running perfectly for the past 1-2 weeks without an issue.

Last night I had an incident where someone spilt water all over my mouse causing it to malfunction. The next time I powered my PC on it just kept switching off by itself. I unplugged all the usb connections and still the same.

I have so far taken out the CMOS battery and I have ordered some more to replace it. I have also removed the case switch cables from the motherboard.

What can I do about this?

SPECS:
i9 10900k
3080 ti
32gb ram
Asus maximus formula XII
My PSU is a RM1000i
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

You're advised to breadboard the system, inspect the motherboard for any signs of blown or burnt components on said motherboard. Then connect with bare minimum components and see if you get signs of life from the system with a donor mouse that didn't see any water spill over it.
 
Feb 6, 2022
2
0
10
Welcome to the forums, newcomer!

You're advised to breadboard the system, inspect the motherboard for any signs of blown or burnt components on said motherboard. Then connect with bare minimum components and see if you get signs of life from the system with a donor mouse that didn't see any water spill over it.

Okay so I removed all unnecessary components from the motherboard and PSU and still the same issue arises. I don’t have a spare mouse at the moment but I plugged in my keyboard and it showed no signs of life (I mean the PC only starts up for about 2-3 seconds, even then the keyboard doesn’t light up)

Is it possible that my water covered mouse may of caused my motherboard to malfunction?