[SOLVED] PC keeps switching boot device

Jan 27, 2022
13
1
25
1
Whenever I shut down or restart my computer it'll change from my M.2 SSD to my SATA Hard Drive. I have installed this hard drive recently and only recently removed windows from it. I have tried changing the boot priority but it changes back after turning my computer of and then back on.

Intel(R) Core(TM) i3-10100 CPU @ 3.60GHz 3.60 GHz
Nvidia GTX 970
Samsung 980 NVMe PCIe M.2 SSD 500GB
Toshiba DT01ACA100 1TB HDD
Corsair Vengeance LPX DDR4 3200 C16 2x8GB
ASRock B560-ITX/ac
 
Last edited:
Jan 27, 2022
13
1
25
1
Ok I believe I have found an fix. I used minitool partition and deleted the recovery partition and then went back into my bios and changed the boot option 1 to my SSD and boot option 2 to Disabled.
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

My first thought is that you should check the motherboard's User Guide/Manual.

There may be a conflict between the M.2 and the SATA hard drive.
 

punkncat

Distinguished
Ambassador
I would suspect that you still have a "boot" or recovery partition on the drive you added.

You may be able to go into your boot order via BIOS and just disable all the other possible options. Just remember that you did that next time you try to load a new OS via USB (etc.).
 
Jan 27, 2022
13
1
25
1
Update your post to include full system hardware specs and OS information.

My first thought is that you should check the motherboard's User Guide/Manual.

There may be a conflict between the M.2 and the SATA hard drive.
This was indeed the case as with an M.2 SATA3_0 would be disabled. However after changing to SATA3_1 it still changes back to the hard drive
 
Jan 27, 2022
13
1
25
1
I would suspect that you still have a "boot" or recovery partition on the drive you added.

You may be able to go into your boot order via BIOS and just disable all the other possible options. Just remember that you did that next time you try to load a new OS via USB (etc.).
I was thinking the same thing however I have tried disabling it and it doesn't work
 
Jan 27, 2022
13
1
25
1
Ok I believe I have found an fix. I used minitool partition and deleted the recovery partition and then went back into my bios and changed the boot option 1 to my SSD and boot option 2 to Disabled.
 

ASK THE COMMUNITY