Question PC monitors keep getting "No Signal" randomly

Apr 1, 2019
7
0
10
0
Hey, my pc keeps randomly cutting the signal to my monitors as all three monitors I own get not signal pop up simultaneously and I have no idea why.

It seems to be a recurring issue I have had for over 2 years now, which is a hella long time for such a persistent issue. I have done so much overtime to fix the issue, but I do certain things and it doesn't occur for a while then all of a sudden it pops up again.

I have:
Gone back and fourth installing and removing different software
Completely wiped my pc and started from new.
Bought a new high end PSU thinking my old one was the issue
Gone through so much of my pc's configs its unreal

I just cant seem to find what the problem is, any help would be great ty.

Pc specs
CPU: Intel® Core™i7 Six Core Processor i7-4930K (3.4GHz) 12MB Cache
CPU Cooler: NZXT RL-KRX62-01 280 mm Kraken Series All-in-One Liquid Cooler - Black
GPU: MSI GTX 970 Gaming 4G Twin Frozr
Motherboard: ASUS® P9X79 LE: INTEL® SOCKET LG2011
RAM: 16GB KINGSTON HYPER-X FURY DUAL-DDR3 1600MHz (2 x 8GB)
HDD: 2TB 3.5" SATA-III 6GB/s HDD 7200RPM 64MB CACHE
SSD: Samsung 850 EVO 500 GB 2.5 inch Solid State Drive
PSU: Seasonic Prime Ultra Platinum 750W 80 Plus Platinum Modular Power Supply

Monitor 1: LG 25UM58-P 25-Inch 21:9 UltraWide FHD IPS Monitor - USING HDMI
Monitor 2: Samsung S22F350 22-Inch HDMI LED Monitor - USING DISPLAY PORT TO HDMI
Monitor 3: Some AOC 720p monitor - USING DVI-D TO VGA
 
Apr 1, 2019
7
0
10
0
Still having the problem if anyone has any ideas

It is really odd as it doesn't happen after a certain activity, time or anything. it just randomly occurs so its hard to say what is causing the problem, the event manager is not doing anything anyway
 

ASK THE COMMUNITY

TRENDING THREADS