Question PC not booting after BIOS updated.

Oct 22, 2020
6
0
10
0
Yesterday, 22/10/2020, I updated some of my out of date drivers from the Asus website. I downloaded most of them including BIOS for my H110M-K.
After restarting my PC after the BIOS update, it wouldn't boot after the ASUS loading screen. I did multiple CMOS Resets. Still nothing.
I got onto the BIOS menu a couple times and I flash updated the BIOS to the current one and the previous one but still nothing. I also attempted to go to safe mode, however it didn't work.
I left it for 3 hours without any power, battery turned off, cord taken out and something different happened.

This is what happened 3 hours later.

I would greatly appreciate any support and if you need my specs i'm happy to put them in the comments.
If the support still doesn't work, i'm happy to go to a repair shop or get a new motherboard in general but only IF it doesn't work.
Thanks in advance.


EDIT: I just checked the inside again and the fan of my Corsair RM650X and it was not running. The keyboard's caps lock light is not turning on when I press caps lock. My USB microphone light is also not turning on.
 
Last edited:
Oct 22, 2020
6
0
10
0
so the pc now have no power?
since you took out the cmos battery earlier, recheck the power to the motherboard
It has power, just got told that I'm going crazy. I just got an email back from Asus and apparently its bricked. I'm just going to get a new one.
 
After restarting my PC after the BIOS update, it wouldn't boot after the ASUS loading screen.
Updating BIOS, resets BIOS settings.
You need to revert to previous values (before update) on settings that are related to boot process.
Boot mode - UEFI boot/legacy boot,
CSM support - enabled/disabled,
Sata controller mode - ahci/Intel RST/raid.

If those settings are different than before, system will not boot anymore.
 
Oct 22, 2020
6
0
10
0
Updating BIOS, resets BIOS settings.
You need to revert to previous values (before update) on settings that are related to boot process.
Boot mode - UEFI boot/legacy boot,
CSM support - enabled/disabled,
Sata controller mode - ahci/Intel RST/raid.

If those settings are different than before, system will not boot anymore.
I probably changed one of those when I updated it.
 

ASK THE COMMUNITY

TRENDING THREADS