• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question PC Not booting after moving

Tabbin

Honorable
Jan 11, 2015
33
0
10,530
0
Hello,

I recently moved my PC without any issues until I came to turn it on and it did not turn on.

I noticed the motherboard had its usual lights on and that all the cables are secure.

I first tested the psu with the paper clip test and it worked fine.

I then tried the motherboard jump start test and it did not turn on, which im guessing the issue is. Im confused though, since the mobo lights are on as usual.

Asus x99-A ii mobo
I7 7700k cpu
16gb ddr4 corsair ram
Nzxt s340 case
Msi 1080 gpu

Any help is greatly appreciated!
 

Ralston18

Titan
Moderator
This:

"all cables are secure" - internal or external?

Are your plugging into a wall outlet, UPS, surge protector, power strip, etc.? Are you certain that that power source is working?

If you are using a power strip or surge protector check the reset button. It may have been tripped during the move.

Power off, unplug, and open the case.

Check that all internal cables, card seatings, RAM, jumpers, etc. are fully and firmly in place.

PSU: make, model, wattage, age, condition?
 

ASK THE COMMUNITY

TRENDING THREADS