Question PC not booting

May 23, 2020
4
0
10
0
Hi all, so I recently decided to upgrade my PC, the only parts I kept was some excess ram i decided to keep in the pc alongside two new 16 Gb sticks. I also kept my old motherboard and SSD that I wiped. Everything else is brand new.

I finished building it and went to boot it up and to my surprise nothing is showing up on the monitor. I made sure the monitor was okay and I made sure I plugged in all the cables in the PC in the right place. I’m running out of hope and ideas as to why this PC isn’t working.

specs:

https://pcpartpicker.com/list/mxsT9G

Video of Ez Debug Light on the Mobo:
Acoording to the user manual, if there was an issue with the pieces like the CPU, the lights would stay on. Instead they are in an endless loop of turning back on and off, only two go on however

I’m genuinely just confused and upset :/
 
May 23, 2020
4
0
10
0
Ive tried nearly everything on that thread multiple times and I’m still getting the same ez debug message, I still have yet to check the pins on my cpu however. They most definitely weren’t bent when I put it in so I’m kinda holding off on that. The cpu seems to be getting recognized too, the ez debug would stay on if that was the issue, so I’m just confused as to why nothing is posting

Edit: found the reason why it wouldn’t boot, I moved one stick of ram I already had around and found a slot where it was recognized, now this brings on another issue, how do I get the computer to recognize the ram in the other slots, I tried putting them in the other slots after and I just keep getting the same ez debug message :/
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS