Question PC Not fire up.

Nov 7, 2018
11
1
15
0
Hi Guys,

I’ve been frustated for days don’t know the causes.

I tried to boot up but nothing shows on my screen.

I have many conclusions here;

1. I tried twice to change the CPU AIO Coolers and replace the thermal paste, I’m using Arctic MX-4. And some of the paste are slightly out of the Processor. Is it safe? Because it’s only tell me “CPU” Word without mention the Code on the Motherboard. (Look at the picture)



2. Is that necessary to put the CPU Connectors Pin from the PSU to the motherboard? (4+8 Pin > CPU Port on PSU) because I leave it and just using the 24 pin instead.

3. I’m going to Use the Kraken G12 on my RTX 2080. But I’m not connecting the Pump or the Bracket yet because it’s still on shipping progress. I removed the blackplate and the Heatsink already. I’m not sure if it’s already dead or not that’s why I tried to boot just to check everything normal.


Can somebody tell me what The Problem it is? The CPU / GPU / PSU Connections?

Ph i forgot to tell you as well, that the AIO Pumps (Kraken X72) isn’t not showing anything when I tried to boot, the fans on the radiator not even running.


Thanks in Advance,
 
Nov 7, 2018
11
1
15
0
full system spec? include make and model of the psu

does the system work before?
Yes, it’s works fine on my previous Case. Now I just migrating to a New Case.

-Intel Core i7-8086K
-MSI RTX 2080 Gaming X Trio
- 32 GB Corsair RGB
-ASUS Maximus XI Formula
-NZXT Kraken X72

I’m pointing this is my GPU Problem that might be dead, but I’m not really sure since the Kraken X72 (AIO Pump) isn’t even turn up even the Fan Radiator isn’t running. I’m assuming the Processor is broken as well due to Thermal Paste is messed up.
 

ASK THE COMMUNITY

TRENDING THREADS