Question PC not starting up after flashing BIOS ?

Sep 10, 2021
So I have been in for a bit of a ruckus lately, with waking up the other day and one of my monitor displays not working (I have 2).
The one that wasn't working was using a DisplayPort cable, the one that was was using a HDMI cable, so I swapped the HDMI to he other and it worked normally.

So I started looking to update all my drivers, connecting to my PC through the HDMI cable (connected to my GPU, if I connected it to the motherboard nothing happened / no signal, if I connected DP to either GPU or motherboard, no signal). I updated the graphics drivers, monitor drivers, everything, and nothing changed.

Then I changed to hardware mode, in which case I opened my only a few weeks old computer and took out the RAM, the GPU, after which I reseated the RAM sticks aswell as the GPU. I tried booting but nothing had changed.

I then tried to take out all the RAM sticks aswell as the GPU, and boot with only CPU / PSU / M.2 SSD / SSD, but despite now letting my motherboard fall onto its integrated display, connecting the HDMI cable directly through the motherboard output gave no signal, resulting in not being able to access the computer at all.

I then figured it had to be the BIOS needing an update, so I plugged in my GPU, and tried to boot into BIOS mode. At first I tried just restarting as normal, but when the ASUS logo usually appears and its my time to spam click "F2" or "DEL", nothing appeared (I still spam clicked though), but it just booted as normal into windows mode.

I tried a few more times, and decided to try the "reboot into UEFI mode" windows option, which, when I rebooted first made the blue screen saying "HDMI no signal", and then it turned black. My computer was running, but apparently no signal to the monitor. (Cable now connected to the GPU, not the motherboard as that didn't give any signal anyway). I think I managed to get into the BIOS? Seeing as when I pressed the power button on the casing, my computer turned off immediately. (I could now boot into Windows, but when trying to reboot into BIOS I got no signals to the monitor)

I kept trying to reseat the RAM sticks, booting with only one stick active, booting without GPU trying to let my motherboard default to integrated graphics but no changes. Eventually when I booted with my GPU installed not even HDMI was working anymore, and I was unable to access my computer altogether.

I then read further, and figured out that my ASUS motherboard has a flash function where I never have to get into the computer, just insert a USB and press a button on the motherboard to let it download, which I did. (Following the official ASUS guide)

After doing it once, there was no change, but I know this might help as I had been playing around with the button before (I thought it was a reset switch to the power to the motherboard itself, as my last motherboard has this, oops.. ;p) Either way, nothing changed, so I tried again a few more times, in case I did something wrong the first time, but nothing changed.

So I decide to reset the CMOS completely, taking out the clock battery on the motherboard, holding in the power button of the computer for one minute++ and turning off the main battery / remove power cable. None of which worked.

I tried booting a few more times with/without GPU, with no RAM, flash the BIOS, nothing changing anything. I am pretty sure my computer never booted into windows at this point as I had no I/O connected to the motherboard (no keyboard/etc), and whenever I pressed the power off button it turned off straight away (when in windows u need to hold it down for 4+ seconds).

I decided to attempt to reset the CMOS one more time, taking the battery out for a long time (30+ min), before putting it back in.

I rebooted without a GPU, but with everything else installed and the first time I booted after plugging in power it started to run for half a second before turning itself off. On further attempts I couldn't even start the PC (Power button does nothing).

When plugging the PC to power, there are still lights inside (on the GPU, the motherboard and the chassis fans), I have also tried to flash the BIOS a few more times, in which case the computer started for 0.5 sec the first time I pressed the power button and then nothing. On recent tried not even flashing the BIOS works.

What could be wrong? Did I short circuit something on the motherboard? (by flashing the BIOS somehow)