Question PC not turning on! Help!

Feb 22, 2021
3
0
10
0
(Note: I have a decent understanding of how a PC works and all of the components go together but please ask because I may have missed something simple when assembling it)

———My parts are listed at the bottom——-
My friend recently gave me an oldish PC of his because he was building a brand new one, he took apart the old one to clean it before giving it to me, when he put it back together to test it, it didn’t work. He then gave it to me for free and said I could keep it but I’d have to fix it. When I plug it in and turn it on, the fans all turn on and I can hear the hard drive spinning, however, it doesn’t send a signal to my screen,

I have tested the PSU with a multimeter and all the voltages are correct for the 2x12 mobo connector. The GPU has been tested in a different computer, it works The cpu is used off of eBay, but it is in perfect physical condition, has not been tested in a different computer Ram has not been tested in a different computer, —(is there any way to do that?)— but is what’s been previously used in the system

———————-Components ————————-

I’m using an old (ish) TV, I believe it’s an IPS panel, I’m sure it does not do 4K, I think it’s probably 60hz
mobo: Gigabyte Ga- 78LMT (rev 2)
Cpu: Amd FX-4300
Gpu: Msi GeForce GTX 1050 TI 4gt OC
Ram: G.Skills Ripjaws X series (2x4gb) (ddr3 1333)
 
Feb 22, 2021
3
0
10
0
So you know, that's probably the motherboard that have a problem..., did you tried to remove the battery for 5 minutes, and reset CMOS ?
The flat Bios battery under the gpu? I haven’t specifically taken it out for 5 mins but I’ve replaced the battery. Resetting the CMOS is that the 2 pins at the bottom that you can jump to reset the bios?
 

rickypicky5

Commendable
Sep 9, 2019
777
90
1,240
52
(Note: I have a decent understanding of how a PC works and all of the components go together but please ask because I may have missed something simple when assembling it)

———My parts are listed at the bottom——-
My friend recently gave me an oldish PC of his because he was building a brand new one, he took apart the old one to clean it before giving it to me, when he put it back together to test it, it didn’t work. He then gave it to me for free and said I could keep it but I’d have to fix it. When I plug it in and turn it on, the fans all turn on and I can hear the hard drive spinning, however, it doesn’t send a signal to my screen,
I'd recheck all the internal connections. In particular, I'd reseat the GPU into the motherboard PCIE slot, and, if it has an external power connector, make sure it's fully inserted into the GPU with the other end into your PSU. If it worked before he took it apart, it should work after he put it all back together.
 
Feb 22, 2021
3
0
10
0
I'd recheck all the internal connections. In particular, I'd reseat the GPU into the motherboard PCIE slot, and, if it has an external power connector, make sure it's fully inserted into the GPU with the other end into your PSU. If it worked before he took it apart, it should work after he put it all back together.
I have reseated everything including ram sticks and gpu, still nothing
 

ASK THE COMMUNITY

TRENDING THREADS