Question PC not working after changing the motherboard ?

Jan 14, 2021
61
3
35
0
So I recently got a new motherboard, plugged it all in then realised I'd need to download the latest bios on a USB stick so I unplugged it all and plugged my old motherboard and everything back in to download it and it won't turn on. The motherboard lights are on, but nothing turns on even after I've checked all the wires. I tried to jump the motherboard but it still didn't turn my machine on. My specs are

Asus Prime B450-M A-II and I was trying to upgrade to Asus rog B450-F Gaming 2.
16gb corsair vengeance rgb Pro + memory rgb Enhancement Kit.
Corsair H100i AIO,
Sapphire RX 580 gpu
EVGA 600w psu.

I'm so confused because it worked earlier today before I unplugged it all.
 

Lutfij

Titan
Moderator
EVGA is the brand while 600W is the wattage of the unit. How old is the unit? When you swapped the motherboard, did you reinstall the OS? Was the latter board on teh latest BIOS update? Speaking of updates, you forgot to mention the processor you're using.
 
Jan 14, 2021
61
3
35
0
EVGA is the brand while 600W is the wattage of the unit. How old is the unit? When you swapped the motherboard, did you reinstall the OS? Was the latter board on teh latest BIOS update? Speaking of updates, you forgot to mention the processor you're using.
Never mind i sorted it,turns out a pin was a little bent,as soon as i rebent straightened it and put the cpu back in it was fine.Thanks in the meantime!
 
Reactions: Lutfij

ASK THE COMMUNITY

TRENDING THREADS