Question PC only runs after pressing power button multiple times, and there's no display ?

May 22, 2022
3
0
10
0
My pc only runs when I press the power button multiple times and when the pc turns on it shows no display.

Solutions ive tried:
-Remove cmos battery
-Clean and reseat ram
-Also tested psu with paper clip -to see if the psu was the problem
-tried powering the pc on using a screwdriver and it still happens
-tried using on board graphics
-replaced cmos battery
-tried different monitors
-tried different power cables
 

Lutfij

Titan
Moderator
When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

tested psu with paper clip -to see if the psu was the problem
That test is pointless, it doesn't tell you how much power the PSU can output effectively to all the components at any given time. The test merely shows it to have some form of life, that life can be as little as 10W even.
 
May 22, 2022
3
0
10
0
When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

tested psu with paper clip -to see if the psu was the problem
That test is pointless, it doesn't tell you how much power the PSU can output effectively to all the components at any given time. The test merely shows it to have some form of life, that life can be as little as 10W even.
Cpu:c2q q6600
Motherboard:asrock g41c gs 2.0
Ram:samsung ram 4gb
Hdd:toshiba 1tb
Gpu:gtx 750ti
Case: unknown
Os:windows 10
 

ASK THE COMMUNITY