[SOLVED] PC only shows Lenovo splash screen

Jan 12, 2020
6
0
20
1
Howdy, I've recently shut down my PC. After powering it back up, the word "Lenovo" shined on my screen, no "loading" icon. Out of nowhere.

I have an SSD as my boot drive with Windows 10 on it. I have a 1TB HDD for storage. Both seem to be working: PC says there's no OS upon removing the SSD and if the HDD is broken, it wouldn't cause this problem.

I've also tried the CMOS battery put-in-and-back method, again, no dice.

Oh, also, pressing keys on my keyboard doesn't do anything. Not even toggle caps lock. I know it is powered because the numlock light is on. I tried other keyboards, so this also isn't the issue.

Update: motherboard is fine, judging by beeping when starting it with no RAM.

Any suggestions?
 
Last edited:
Jan 12, 2020
6
0
20
1
Hello, I'm writing to inform that I managed to fix the issue myself.
Either it was a faulty SATA cable or a Win10 corruption. I'm currently in the process of reinstalling Win10 on the SSD entirely.
Thanks for the advice, though!
 

Vic 40

Polypheme
Herald
When starting the pc/laptop just after pushing the button start tapping F2 or F1 or F12,see if you can get into the bios. Try each after a restart if the one tested didn't work.

If you can get into the bios see that you can set the bios to optimal default values,after that get into the bios again and set the ssd as bootdisc,see if this helps.
 
Jan 12, 2020
6
0
20
1
Hello, I'm writing to inform that I managed to fix the issue myself.
Either it was a faulty SATA cable or a Win10 corruption. I'm currently in the process of reinstalling Win10 on the SSD entirely.
Thanks for the advice, though!
 
Jan 12, 2020
6
0
20
1
I wiped the SSD with diskpart with another computer of mine and then installed Win10 on a USB. Plugged everything back in my PC and reinstalled the OS.
 

ASK THE COMMUNITY

TRENDING THREADS