[SOLVED] PC power keeps turning on and off and on after upgrading ram

anaxgorous1

Prominent
Jul 27, 2019
37
1
535
0
Specs:
MOBO: Asrock B450M Pro4-F
CPU: Ryzen 5 2600
GPU: Nvidia GTX 1650
PSU: GP550 Aigo 80+Bronze
RAM: Old 8GB Kingston, 8x2GB Kingston Hyperx

New ram just arrived and installed it firmly on the ram slots, booted up pc and the problem mentioned in title occurs, removed new ram replaced with old ram with the same slots as before but problem still persists, prior to this literally before replacing the rams my pc was working fine. I have no idea what went wrong and I hope its not the PSU because it was working fine just seconds ago.
The fan inside the pc will run and after 5-10 seconds turn off and turn on again shortly after.

edit: Windows does not bootup and my monitor does not receive any signal if that matters.
 
Last edited:

Vyrvelata

Notable
Are you sure you didn't move or unplug something while you change your ram?

Check your power cables ( remove your power cord from the PSU 1st)...
Try with only 1 stick of ram...
Remove your motherboard battery in case you wasn't able to reset the bios properly (leave the PC without power and without battery at least for 5 mins).
 
Reactions: anaxgorous1

Vyrvelata

Notable
Are you sure you didn't move or unplug something while you change your ram?

Check your power cables ( remove your power cord from the PSU 1st)...
Try with only 1 stick of ram...
Remove your motherboard battery in case you wasn't able to reset the bios properly (leave the PC without power and without battery at least for 5 mins).
 
Reactions: anaxgorous1

anaxgorous1

Prominent
Jul 27, 2019
37
1
535
0
Are you sure you didn't move or unplug something while you change your ram?

Check your power cables ( remove your power cord from the PSU 1st)...
Try with only 1 stick of ram...
Remove your motherboard battery in case you wasn't able to reset the bios properly (leave the PC without power and without battery at least for 5 mins).
I tried using the old ram and it still didn't work, I may have moved the cables by accident because it was getting in the way but I didn't unplug the cables because I was scared that i would accidentally break something.

But thanks for trying to help, I went to my local repair shop immediately and fixed it because I needed it for schoolwork, it was probably the cable's problem.
 

ASK THE COMMUNITY