Question PC powers on and I can see lights and fans running but nothing else happens. Nothing on monitor, keyboard not on, mouse not on, nothing.

Nov 18, 2020
1
0
10
0
PCPartPicker Part List

CPU: AMD Ryzen 5 5600X 3.7 GHz 6-Core Processor
Motherboard: Asus TUF GAMING B550M-PLUS Micro ATX AM4 Motherboard ($149.69 @ Amazon)
Memory: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3200 CL16 Memory ($68.99 @ Corsair)
Storage: ADATA XPG SX8200 Pro 2 TB M.2-2280 NVME Solid State Drive ($249.99 @ Adorama)
Case: Fractal Design Meshify C ATX Mid Tower Case ($95.99 @ B&H)
Power Supply: Antec NeoECO Gold ZEN 700 W 80+ Gold Certified ATX Power Supply
Operating System: Microsoft Windows 10 Home OEM 64-bit ($108.78 @ Other World Computing)
Total: $673.44
Prices include shipping, taxes, and discounts when available
Generated by PCPartPicker 2020-11-18 07:49 EST-0500


Graphics card is a geforce 1060 6gb i took from my old comp. not sure who manufacturer is.

I finished building the PC and plugging everything in and I turned it on. I see lights and fans running inside the case. But nothing shows up on my monitor, my mouse and keyboard don't light up. Nothing else happens.

I thought maybe the BIOS needed an update since the ryzen 5000s just came out. I flashed it and didn't really know what I was doing. The first time I put the USB (it was fat, BIOS file was renamed and in root) in and pressed the button and it flashed for some seconds then turned solid. I don't remember how long I waited for before turning the PC on. The BIOS I used was the beta version.

The second time I tried to flash it again. I'm not sure if I did it on the same USB or a different one. This time I did some stuff and took a shower and came back and took a shower and the light was solid. I turned the PC on and nothing happened like described above and I turned it off. This time I used the BIOS right before the beta one.

I tried for a third time on a different USB. It was fat32. BIOS file was in root directory and renamed as usual. This USB had a whole bunch of other files on it too, not sure if that affects it. I acquired the BIOS version by going to the list of compatible CPUs for my motherboard on their website, scrolling to 5600x and clicking the link provided. I put in the USB, press the flash button. The light turns on and flashes for a few seconds before remaining solid for a good 20-30mins.

I was going off the BIOS flashback instructions on the ASUS website and upon further inspection and reading some QandA down the bottom, I discovered that a solid light after flashing means the BIOS flashback isn't working properly.

So here I am at a loss and having no idea what's wrong.
 
Nov 18, 2020
17
4
15
0
Well I'm sorry to say that idk how to fix that, all I wanted to say is congrats on the 5000 series CPU. The motherboard should be compatible, I don't know much about updating the BIOS but I definitely feel like you're doing the right thing. GL!
 

ASK THE COMMUNITY

TRENDING THREADS