Question PC Randomly turns off and then immediately back on - please help!

Apr 14, 2019
3
0
10
0
Hey there good people of Tom's Hardware. I come seeking your great wisdom, and humbly beg for you to bestow upon me your knowledge and aid.

To give some backstory, about a month ago, my pc was having a slighty similar but different enough problem. When I tried to turn it on, it would power on for about 3 seconds before turning back off. I figured it was a problem with the PSU and got a replacement via RMA, but that didn't fix it. So i took it to a pc repair place and the guy told me it was probably the motherboard. Had a spare lying around, so i swapped everything over to the new board. Boom, instant success, everything worked perfectly.

For about a month or so, it's been totally operational. However, within the last few days it has started to randomly turn off (the MB lights also turn off) and then turn back on. I've watched the CPU temp and everything seems normal, the PSU fan is spinning, windows memory diagnostic tells me the RAM is functioning fine.

I really don't know what the problem could be. Did I just get unlucky and receive a bad PSU, or have another bad MB? Is it the processor, but a non-heat-related issue? Please help!
 
Apr 14, 2019
3
0
10
0
full system spec? include make and model of the psu
cpu/gpu temp and usage?
CPU: Intel i7 7700k (not currently overclocked)
CPU cooler: CoolerMaster Hyper 212 EVO
RAM: Ballistix sport ddr4 2x4gb
MOTHERBOARD: MSI B250 PC Mate
Hard drive: WD blue 1TB
SSD: SanDisk 500GB
PSU: EVGA Supernova NEX750G

Don't currently have a GPU, but I'll be getting a 1050ti in tomorrow night.

CPU isn't getting any hotter than 65c or so.

Thanks for your time
 
Apr 14, 2019
3
0
10
0
UPDATE: Hey guys, I've been messing with it and trying to do some troubleshooting for a few days now and here's what I have to report.

It ran smoothly for two days or so with only one stick of RAM, so I tried putting in the 2nd stick. That worked for a day until it started rebooting again. I'm now running just the first stick again, but the rebooting is still happening.

During one of the reboots, Windows attempted to troubleshoot itself and suggested I reinstall Windows. I've not done that yet, just becaus it seems strange that it would reboot if it was a Windows error. I specifically turned off the auto reboot for windows errors.

Usually, what happens is that the first time I turn on my PC for the day, it doesn't reboot at all for maybe 3 hours. But then once the reboot occurs, it seems to keep happening with increasing frequency. At the moment, I can't even be on the desktop for more than 10 minutes before it reboots.

Would really love and appreciate any advice you could give me. This seems to be a pretty crazy problem and I'm not sure what to do about it
 

ASK THE COMMUNITY

TRENDING THREADS