Question PC refuses to post - black screen, mouse and keyboard as well

May 24, 2023
Hi everyone,

I recently encountered a problem with my PC after updating my BIOS a couple of days ago through Gigabyte's App Center software in Windows. It seems that something went wrong during the installation process because my PC didn't turn off and remained on without displaying anything on the screen. I've even waited for an additional 30 minutes before giving up and resorting to a reset. Since then, I haven't been able to successfully boot my PC as I'm greeted with a black screen, and my keyboard and mouse also don't seem to be functioning. However, all other components such as fans and RGB lighting appear to be working fine.

To address this issue, I've attempted several solutions with no success:

1. I tried installing the latest BIOS version downloaded from the Gigabyte website using q-flash+. I made sure to follow the instructions provided by Gigabyte and renamed the file to "gigabyte.bin."

2. I performed a CMOS battery reset by removing it, waiting for approximately 5 minutes, and then reinserting it.

3. I attempted a CLR CMOS operation by using a screwdriver to clear the CMOS jumper.

4. I reseated the CPU, GPU, and RAM in an effort to resolve any potential connection issues.

Interestingly, I managed to successfully boot into Windows after reverting to an older BIOS version (version 14) and performing a CMOS reset, as well as booting with only one RAM stick in different slots. However, the problem resurfaced after resetting the PC, and I found myself unable to boot once again.

Considering my PC is relatively new, I suspect that the BIOS or motherboard is the root cause of the problem. I'm quite frustrated with Gigabyte's App Center as it recommended downgrading from BIOS version 15c to version 14, unaware that I already had a newer BIOS installed. Now, I'm unable to find version 15c in their downloads section.

My question is whether I should proceed with requesting an RMA for the motherboard, or if there are any other troubleshooting steps I should attempt before pursuing that option.

Here are my system specifications:

- Motherboard: Gigabyte B550M Aorus Pro-P Rev 1.0
- CPU: AMD Ryzen 5600X
- GPU: Radeon 6600 XT PowerColor Red Devil
- Storage: Samsung SSD 970 Pro NVMe M.2 1TB
- RAM: 8GBx2 Corsair Vengeance RGB Pro 3200 CL16, 8GBx2 Corsair Vengeance RGB Pro TUF Gaming Edition 3200 CL16
- Power Supply: Antec HCG Gold 650W

Thank you in advance for any assistance or suggestions you can provide.
did you clear the cmos while power was unplugged from the wall?

why did you reset your PC while it was working? After not booting, could you get into BIOS? was the boot order correct?

try BIOS version 16C, don´t use the app center in windows, enter BIOS and use q-flash again from there
May 24, 2023
Hi @helpstar

Thank you for suggestions and follow-up questions. To address your inquiries:

- Yes, I did clear the CMOS while the power was unplugged from the wall. I wanted to ensure a proper reset.

- I reset my PC because I was attempting to access the BIOS. In hindsight, I should have pressed the "Delete" key during the boot process to enter the BIOS directly or even update the drivers before resetting. Unfortunately, I wasn't able to get into the BIOS, and the boot order seemed correct.

Regarding BIOS version 16C, I did try it initially but encountered no success. However, I will give it another shot as you suggested. Once I manage to boot the PC, I will promptly enter the BIOS and use q-flash from there to update the BIOS.

I appreciate your guidance and will keep you informed of any progress or outcomes. Thank you again for your assistance.
  • Like
Reactions: helpstar
May 24, 2023
Hi there,

I wanted to provide an update on the issue I was facing with my PC. After some troubleshooting, I was able to resolve the problem.

I borrowed a set of RAM sticks from a friend and installed one of them. Surprisingly, my PC successfully booted all the way to Windows. However, when I tried replacing my friend's RAM with my own, the PC refused to boot again, regardless of what I tried.

To troubleshoot further, I downloaded the latest BIOS version from the Gigabyte website. I also tested all four of my RAM sticks in my friend's PC, and they worked perfectly fine. This leads me to believe that the issue lies in some sort of compatibility problem with the motherboard's BIOS or settings. I even attempted to clear the CMOS and reset to optimized settings through the BIOS, but unfortunately, nothing seemed to work.

Fortunately, my friend kindly agreed to swap RAM sticks with me, so I now have a working PC. However, the whole situation remains quite perplexing. I'm planning to have my friend run a memtest on my original RAM sticks to see if there's anything wrong with them. I'll keep you updated on the results.

Thanks for your support.
  • Like
Reactions: monere