• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Pc restart after playing for a while or when I begin a heavy Furmark test ( with a loud voice from my rx570)

el_shekoo7

Prominent
Apr 25, 2019
32
1
535
0
It goes to black screen ( the one with no signal text ) first for about 5 seconds with a loud voice from my GPU ( used RX 570, which was working fine from the last September when I got it, used mainly in gamin max 4-5 hrs a day and not every day), I know my PSU is not that great but when I asked the local shop I got the GPU from he said it's good enough to work with the rx570, its a( Coolermaster ex2 525w) which is working fine for a long time maybe about 2-3 years.
other than that it works completely fine without random crashes or stuff like that.
well, i hope it's the psu but is there any way to make sure of the dying piece here psu or gpu?

Thanks
 

el_shekoo7

Prominent
Apr 25, 2019
32
1
535
0
Dear God, no.

That thing is ancient garbage.
hahaha, unfortunately I live in Egypt so a lot of pieces are outdated here and newer ones are extremely expensive in the local currency, I had a long time ago with my previous gt1030 I was going to replace when got rx570 but the shop told it's not that necessary and it'll work fine.
I wish it's the PSU fault but how it was running perfect for all these months running heavy games like RDR2 for example, it's confusing!
 
hahaha, unfortunately I live in Egypt so a lot of pieces are outdated here and newer ones are extremely expensive in the local currency, I had a long time ago with my previous gt1030 I was going to replace when got rx570 but the shop told it's not that necessary and it'll work fine.
I wish it's the PSU fault but how it was running perfect for all these months running heavy games like RDR2 for example, it's confusing!
Because you were only using a GT1030. That's why it worked.

Get a better PSU.
 

el_shekoo7

Prominent
Apr 25, 2019
32
1
535
0
Because you were only using a GT1030. That's why it worked.

Get a better PSU.
Sorry I meant it worked with the rx570 for several months then that problem appeared just yesterday , could it be that the gpu damaged psu! I know it could happen the opposite way that’s why I’m confused which one is dying
 
Sorry I meant it worked with the rx570 for several months then that problem appeared just yesterday , could it be that the gpu damaged psu! I know it could happen the opposite way that’s why I’m confused which one is dying
It's more likely that the PSU damaged the GPU than the other way around.

Seriously. Your PSU is known garbage. Just get another.
 

el_shekoo7

Prominent
Apr 25, 2019
32
1
535
0
It's more likely that the PSU damaged the GPU than the other way around.

Seriously. Your PSU is known garbage. Just get another.
So both are gone!!? That’s hurt.
I’ll change the psu indeed but is there any chance that the gpu is still fine.
And thanks a lot for your time and help,
 

ASK THE COMMUNITY

TRENDING THREADS