Question PC restarts while gaming 'Thermaltake TR2 TR-700 700W 80 PLUS BRONZE '

tatulasha

Honorable
May 4, 2016
19
0
10,510
0
so I have almost 6 years old "Thermaltake TR2 TR-700 700W 80 PLUS BRONZE"

while gaming (sometimes during the launch of any game or during loading) pc crashes and restarts and right after the crash or at the moment of the crash there is an Increase in PSU Performance (it becomes louder tho usually it is quiet)

I cleaned CPU and GPU several times so it is not related to CPU or GPU.

i just want a confirmation if I should change PSU, or is it PSU related problem

EDIT: All pc components

MOTHERBOARD: MSI Z97 PC MATE 5 years old
CPU: Intel Core i5 4690K 5 years old
SSD: Crucial MX500 2TB 3D NAND SATA 2.5 Inch Internal SSD 1 year old, SanDisk SSD PLUS 240GB (System) 3 years old
HDD: Western Digital WD Green WD20EARX 2TB 7200 RPM 64MB 8 years old
GPU: MSI GTX 1080 AERO 8G 3 years old
RAM: Patriot 16GB(2x8GB) Viper III DDR3 1866
 
Last edited:
so I have almost 6 years old "Thermaltake TR2 TR-700 700W 80 PLUS BRONZE"

while gaming (sometimes during the launch of any game or during loading) pc crashes and restarts and right after the crash or at the moment of the crash there is an Increase in PSU Performance (it becomes louder tho usually it is quiet)

I cleaned CPU and GPU several times so it is not related to CPU or GPU.

i just want a confirmation if I should change PSU, or is it PSU related problem
The TR2 are poor quality models. You should list all your system parts for evaluation anyways. It's likely you'll need a new, higher quality PSU.
 
Last edited:

tatulasha

Honorable
May 4, 2016
19
0
10,510
0
The TR2 are poor quality models. You should list all your system parts for evaluation anyways. It's likely you'll need a new, higher quality PSU.
MOTHERBOARD: MSI Z97 PC MATE 5 years old
CPU: Intel Core i5 4690K 5 years old
SSD: Crucial MX500 2TB 3D NAND SATA 2.5 Inch Internal SSD 1 year old, SanDisk SSD PLUS 240GB (System) 3 years old
HDD: Western Digital WD Green WD20EARX 2TB 7200 RPM 64MB 8 years old
GPU: MSI GTX 1080 AERO 8G 3 years old
 
MOTHERBOARD: MSI Z97 PC MATE 5 years old
CPU: Intel Core i5 4690K 5 years old
SSD: Crucial MX500 2TB 3D NAND SATA 2.5 Inch Internal SSD 1 year old, SanDisk SSD PLUS 240GB (System) 3 years old
HDD: Western Digital WD Green WD20EARX 2TB 7200 RPM 64MB 8 years old
GPU: MSI GTX 1080 AERO 8G 3 years old
So no RAM?

Do you have "automatically restart" unchecked?

http://jongerow.com/automatically-restart/index.html
 

ASK THE COMMUNITY

TRENDING THREADS