Question PC running but no display

Dec 4, 2019
3
0
10
0
Curious if anybody could help me with this issue ive been having, A few weeks ago i had my pc on sleep mode over the weekend, when i returned to it and turned it back on, as i was loggin in my screen became very pixelated and colorful and eventually just went black. i first thought it was a windows issue/memory, everytime i would restart it would just bring me to windows blue screen recovery.

Through small research i figured it would be best to just clear all my drives and reinstall windows so thats what i did. when that failed to change anything i figured my drives were junk so i went ahead and got a new m.2

Today after installing it & reinstalling windows everything ran silky smooth for about 30 minutes than just like the first time, my screen went very pixelated to eventually going black. i also recently installed a new graphics card and all the issues started about a week after that so am i wrong to think maybe its the graphics card messing up? because i had also noticed that my graphics card feels noticeably hot to the touch, checked all connections, tried secondary pcie, nothing changed. any help would be greatly appreciated. -shaughn

PC Specs:
OS: windows 10 pro 64bit
MBO: msi b40 tomahawk
CPU: ryzen 7 2700
RAM: Corsair vengeance 4x8gb
GPU: Geforce RTX 2060 super 8gb
PSU: Corsair cx650m
COOLING: Corsair h115i pro AIO 280mm
 
Dec 4, 2019
3
0
10
0
I highly recommend you replace your PSU with a higher quality model. This may also be the cause of your problems. I suggest testing your system with another power supply to see if it's the culprit.
I thought the same initially, but while i was thinking that it was a gpu issue i had tried my old graphics card that i had ran for over a year with no issues ( gtx 1650) and the problem remained persistent so i do i agree i surely need to upgrade my psu but with what i just said im not sure thats my issue at and but i sure could be wrong, i just at a standstill because im trying to avoid just buying new parts for the sake of it and hoping it fixes my issue, really wish there was a way to pin point the problem
 

lolnole

Commendable
Oct 2, 2018
461
16
1,315
117
Actually, I think I misunderstood your timeline. If you installed the graphics card before all of the problems started, then I would definitely be leaning in that direction too. However, since you swapped in the old graphics card and are still having issues, I am circling back towards the PSU as the culprit. The RTX 2060 Super does draw quite a bit more power than the GTX 1060. Have you been stressing the system with the new GPU (e.g. gaming)?

Unfortunately, the only way to test this is to get a hold of another PSU.
 
Reactions: shaughncd1995
Dec 4, 2019
3
0
10
0
Actually, I think I misunderstood your timeline. If you installed the graphics card before all of the problems started, then I would definitely be leaning in that direction too. However, since you swapped in the old graphics card and are still having issues, I am circling back towards the PSU as the culprit. The RTX 2060 Super does draw quite a bit more power than the GTX 1060. Have you been stressing the system with the new GPU (e.g. gaming)?

Unfortunately, the only way to test this is to get a hold of another PSU.
see the odd thing is that i had the 2060 installed and operating with no issues for atleast a week with atleast 2-3 hours of gaming (cod mw w ray tracing on) so for sure stressing the system but i had no issues what so ever and than all of a sudden like i stated in my original post i came back to my pc after a weekend away and logged in off sleep mode and got the black screen, i am currently on my pc and seems to be working somewhat fine, the windows display drivers were mysteriously reinstalled so i deleted them but now my gpu isnt being detected and what i try installing the drivers for it it says it cannot because the drivers are not compatible with this version of windows/ driver could not find compatible graphics hardware, i want to try and reseat my gpu but im afraid to my pc off and it going back to not working at all
 

ASK THE COMMUNITY

TRENDING THREADS