[SOLVED] PC Running Extremely Slow After Reset

keenwads

Prominent
Aug 24, 2018
92
0
660
10
Hi all,
Earlier today I reset my PC in order to clean up space- my PC was running fine with no performance issues. However, after the reset the performance of the PC had significantly worsened, with random stutters and freezes every 30 seconds that last up a minute. According to the windows resource and performance monitor, The CPU, GPU, Memory and Disk ratings of my system are poor, despite me taking good care of them and them having worked perfectly before the reset. Does anyone know how to fix this? Any help would be greatly appreciated.

Specs:
i7 8700
Nvidia GTX 1060
16GB 3000MHZ DDR4 RAM
500W Gold Rated Power Supply
System is installed on a 120gb WD Green SSD
Additional 1TB Seagate Hard Drive is installed
Motherboard is an Aorus z370
 

Colif

Win 10 Master
Moderator
I assume all Z390 have same utilities.
Go to the utility menu and install App Centre. Run it and it will check if you have latest drivers. It may also suggest utilities, many of which aren't really needed.
 

keenwads

Prominent
Aug 24, 2018
92
0
660
10
have you gone to gigabyte website for the motherboard and installed latest drivers? I would have linked to it but Gigabyte have several Z370 motherboards
I have gone to the website but I'm note sure how to install drivers, and I dont want to do it wrong and worsen the situation
 

Colif

Win 10 Master
Moderator
I assume all Z390 have same utilities.
Go to the utility menu and install App Centre. Run it and it will check if you have latest drivers. It may also suggest utilities, many of which aren't really needed.
 

ASK THE COMMUNITY