Question Pc runs for 27 seconds then reboots then repeats this process

Oct 23, 2021
2
0
10
0
I'm new to pc building this is my first build, my pc runs for 27 seconds then reboots. when I remove the psu cpu cable it runs fine. i removed everything 1 by 1 to see what was the problem and my only solution is it'll only run without rebooting when i remove the psu cpu cable. So, should i replace the motherboard or the psu or is there something else wrong or could it be because bios isn't updated.

AMD Ryzen 5 5600X 3.7 GHz 6-Core Processor
ID-COOLING ZOOMFLOW 240X ARGB 62 CFM Liquid CPU Cooler
Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 CL15 Memory
Western Digital Blue SN550 1 TB M.2-2280 NVME Solid State Drive
Phanteks Eclipse P360A ATX Mid Tower Case
EVGA SuperNOVA GA 650 W 80+ Gold Certified Fully Modular ATX Power Supply
ASRock B450M/AC R2.0 AM4 AMD Promontory B450 SATA 6Gb/s Micro ATX AMD Motherboard
ASRock Challenger D Radeon RX 6600 XT 8GB GDDR6 PCI Express 4.0 Video Card RX6600XT CLD 8GO
 
Oct 23, 2021
2
0
10
0
yes it will keep running without it being connected but i haven't connected it to a monitor yet because i wanted to find out what was wrong
 

Juular

Commendable
Mar 14, 2020
941
222
1,640
110
yes it will keep running without it being connected but i haven't connected it to a monitor yet because i wanted to find out what was wrong
What ? So you don't know if it keeps running, or rather it it POSTed at all after all ? It shouldn't work without EPS cable, you're just confusing us. Does the PC actually reboot (with EPS cable connected as it supposed to be) or it's complete shutdown to halt ? Why exactly 27 seconds ? Does it always reboot exactly at the same time ? Did you enable RAM XMP ? Disable if so.
 

ASK THE COMMUNITY