Question Pc Screen with no signals after Secure Boot and TPM turned on

no542

Honorable
Apr 5, 2017
4
0
10,510
0
Good Days to you all! Thank you for taking your time to read this thread.

I seem to have an issue with my computer. Recently black friday sales i got myself an Aorus x570s Pro Ax with Ryzen 9 5900x and I was updating and got the option of getting a free upgrade from windows 10 to 11 and i was told to turn on TPM and secure boot. so being stupid enough i did this under regular bios rather than legacy (UFEI) and i turned on AMD fTPM with secure boot. Now, when it reboots i get no screen signals i can't even go back in bios the pc just turns on but can't seem to post or do anything. Turned off my pc and turn off the switch and unplugged my power source towards psu tried doing Cmos clear battery and the 2 pins but nothing really works. I reseated the ram and took out my GPU and also tried doing the HDMI (on board) but that also didn't solve my issue. i swap a different GPU incase if it was my GPU but that didnt work either. i tried to do a update bios update through flash but that also didn't work. I'm currently looking through all my options but i seem to come to be completely loss here. I know there is a way by replacing a new CPU but i dont really want to invest into another CPU when i just invested into a 5900x. Does anyone have a solution to help me fix? Would greatly appreciated.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
61,162
5,187
166,290
10,454
you lucky, you have an X570, as people in that position on a B450 have all sorts of fun.

That is reaction you get turning on secure boot when drive is still formatted as MBR on Gigabyte boards

What you need to do is flash the bios over the top of itself and it will fix any of the settings that are stopping you now.
Look here at instructions for Q Flash +
https://download.gigabyte.com/FileList/Manual/mb_manual_x570-features.pdf

once you flashed bios, and it lets you back into bios and screen is working, convert the drive to GPT - https://it-infrastructure.solutions/how-to-switch-from-legacy-to-uefi-boot-mode-mbr2gpt-convertion/

Detail you didn't know - You don't have to turn secure boot on to install Win 11, PC just needs to be able to. It doesn't force it
 

ASK THE COMMUNITY