Question PC severely underperforming, stuttering and weird GPU & CPU Usage ?

Nov 23, 2022
22
0
10
0
Hello, so recently i’ve bought myself an RX 6650 XT 8gb Shappire Pulse, i had an RX 580..

But after installing the new gpu my pc was severely under performing.. i was getting wierd usages like 50% CPU 45% GPU in games but very low fps.. sometimes i would also get 100% GPU and 20% CPU or 100-80%CPU and 20% GPU.

in almost every game (low-med-high) graphics i get stuttering.. (on NFS Heat, Evil Dead, CSGO)

my rig
Ryzen 5 3400g
RX 6650 XT
Kingston Fury 16gb (2x8) 3200mHz RAM
600w PWS Bronze/Silver Certified
a320m s2h gigabyte motherboard
Crucial 256GB SSD
Gigabyte 255GB SSD
No Hard Drives.

this i’ve done to “reduce” my stuttering problems but kinda didnt work.

  • Clean GPU DRIVERS install using DDU.
  • installed Amd Chipsets.
  • optimised some windows settings
  • clean windows reinstall.
  • windows downgrade & upgrade.
  • checked if the GPU is installed correctly.
  • checked if the RAM was installed correctly.
  • benchmarked using FurMark and Userbenchmark.. (EVERYTHING WORKED FINE during benchmarks, no problems were found, worked fine)
Image links
View: https://imgur.com/a/aPUuKkw

View: https://imgur.com/a/GF6Yx2f
 
Nov 23, 2022
1
0
10
0
I’m having a real similar issue to yourself I have a Ryzen 5 2600x

muse to have a 1660ti ran no issues other than performance. Swapped it out for a RX6750XT and since it’s not even able to do what my old graphic card used to I thought it was cpu but if it was would be 100% usage

as I said any usage please advice I’ll do the same
 
Nov 23, 2022
22
0
10
0
I’m having a real similar issue to yourself I have a Ryzen 5 2600x

muse to have a 1660ti ran no issues other than performance. Swapped it out for a RX6750XT and since it’s not even able to do what my old graphic card used to I thought it was cpu but if it was would be 100% usage

as I said any usage please advice I’ll do the same
well i’ve personally talked to some people and they told me it could be a CPU bottleneck..
like lets be real.. a 4 core cpu cant handle such a graphics card.. i’ve also done some researching to find a good CPU that would work with my GPU and it would be an Ryzen 5 5600, its also cheap so it wont destroy my wallet.. (its aleardy destroyed tho bc im a student) but yeah.. i suggest you do the same 🤷🏼.
I suspect its a CPU bottleneck becouse with my old GPU my pc used to work the same.. and i personally checked online to see if its a bottleneck or not (after asking friends) and it clearly is on CPU bound games.. like apex, roblox.. on apex it shows i have 20% Cpu bottleneck while on Roblox 72%!
on NFS heat it said i have 0% on 1080p but the information is kinda not real.. as i do have lag spikes stutters and unstable usage on cpu and unstable FPS..

i will change my CPU next week and post if the problem was resolved.. or not..

P.S - i’ve actually looked if your PC is bottlenecked or not and it clearly looks like it!
17% bottleneck becouse of your CPU.
Link here - https://pc-builds.com/bottleneck-calculator/result/0Qb1bh/1/general-tasks/1920x1080/
 
Nov 23, 2022
22
0
10
0
I’m having a real similar issue to yourself I have a Ryzen 5 2600x

muse to have a 1660ti ran no issues other than performance. Swapped it out for a RX6750XT and since it’s not even able to do what my old graphic card used to I thought it was cpu but if it was would be 100% usage

as I said any usage please advice I’ll do the same
new CPU “kinda fixed it”
Upgraded to a 5600g tomorrow im going to a service centre to investigate.. i also have a strange noise while pc is on load now..
 
Nov 23, 2022
22
0
10
0
Hello, so recently i’ve bought myself an RX 6650 XT 8gb Shappire Pulse, i had an RX 580..

But after installing the new gpu my pc was severely under performing.. i was getting wierd usages like 50% CPU 45% GPU in games but very low fps.. sometimes i would also get 100% GPU and 20% CPU or 100-80%CPU and 20% GPU.

in almost every game (low-med-high) graphics i get stuttering.. (on NFS Heat, Evil Dead, CSGO)

my rig
Ryzen 5 3400g
RX 6650 XT
Kingston Fury 16gb (2x8) 3200mHz RAM
600w PWS Bronze/Silver Certified
a320m s2h gigabyte motherboard
Crucial 256GB SSD
Gigabyte 255GB SSD
No Hard Drives.

this i’ve done to “reduce” my stuttering problems but kinda didnt work.

  • Clean GPU DRIVERS install using DDU.
  • installed Amd Chipsets.
  • optimised some windows settings
  • clean windows reinstall.
  • windows downgrade & upgrade.
  • checked if the GPU is installed correctly.
  • checked if the RAM was installed correctly.
  • benchmarked using FurMark and Userbenchmark.. (EVERYTHING WORKED FINE during benchmarks, no problems were found, worked fine)
Image links
View: https://imgur.com/a/aPUuKkw

View: https://imgur.com/a/GF6Yx2f
okay so i’ve ALMOST fixed the issue.. (I THINK
Looks like its RAM & Motherboard related.
XMP was disabled.. and that was giving me like 70% of the stutters..
Also the PSU was kinda faulty im pretty sure.. and it wasnt an good PSU from what i heard (nJoy Theta 650w 80+ Bronze) its a romanian brand that is why is probably unknown to many.. people use it a lot here.. but from what i heard from professionals can be a problematic PSU..
now i got an FSF Hydro G 750W 80+ Gold..

i still have micro stuttering but its very rare.
Also i still have noise coming from my PC.. and its probably Coil Whine.. becouse the PSU got changed.. is Coil Whine normal or should i get my GPU in Service?

usages are still kinda wierd.
95% GPU usage in NFS heat
75% CPU usage in NFS HEAT
Memory about 11gb’s used..

my next upgrade would probably be to swap the ram for 2x16 modules.. and have 32gb of ram..

even tho, its waaaaay waaay better and more playable now.. its clearly a RAM issue.. i think..
 
Nov 23, 2022
22
0
10
0
okay so i’ve ALMOST fixed the issue.. (I THINK
Looks like its RAM & Motherboard related.
XMP was disabled.. and that was giving me like 70% of the stutters..
Also the PSU was kinda faulty im pretty sure.. and it wasnt an good PSU from what i heard (nJoy Theta 650w 80+ Bronze) its a romanian brand that is why is probably unknown to many.. people use it a lot here.. but from what i heard from professionals can be a problematic PSU..
now i got an FSF Hydro G 750W 80+ Gold..

i still have micro stuttering but its very rare.
Also i still have noise coming from my PC.. and its probably Coil Whine.. becouse the PSU got changed.. is Coil Whine normal or should i get my GPU in Service?

usages are still kinda wierd.
95% GPU usage in NFS heat
75% CPU usage in NFS HEAT
Memory about 11gb’s used..

my next upgrade would probably be to swap the ram for 2x16 modules.. and have 32gb of ram..

even tho, its waaaaay waaay better and more playable now.. its clearly a RAM issue.. i think..
UPDATE : There are still lag spikes.. Battlefield 1 shows low latency..
 
well i’ve personally talked to some people and they told me it could be a CPU bottleneck..
like lets be real.. a 4 core cpu cant handle such a graphics card.. i’ve also done some researching to find a good CPU that would work with my GPU and it would be an Ryzen 5 5600, its also cheap so it wont destroy my wallet.. (its aleardy destroyed tho bc im a student) but yeah.. i suggest you do the same 🤷🏼.
I suspect its a CPU bottleneck becouse with my old GPU my pc used to work the same.. and i personally checked online to see if its a bottleneck or not (after asking friends) and it clearly is on CPU bound games.. like apex, roblox.. on apex it shows i have 20% Cpu bottleneck while on Roblox 72%!
on NFS heat it said i have 0% on 1080p but the information is kinda not real.. as i do have lag spikes stutters and unstable usage on cpu and unstable FPS..

i will change my CPU next week and post if the problem was resolved.. or not..

P.S - i’ve actually looked if your PC is bottlenecked or not and it clearly looks like it!
17% bottleneck becouse of your CPU.
Link here - https://pc-builds.com/bottleneck-calculator/result/0Qb1bh/1/general-tasks/1920x1080/
That bottleneck calculator is garbage! Shouldn't even exist!
 
Reactions: Zamfik267
Nov 23, 2022
22
0
10
0
Low latency is good.

Are you getting packet loss?
Yes im getting packet loss..
But i managed to FIX stuttering for battlefield by switching DirectX12 OFF..
For NFS Heat i had to turn XMP on.. and solved 99% of the issues..
Phasmophobia & Roblox dont have any problems at all and never had.

the only game i have problems on right is Evil Dead The Game.. a lot of stuttering.. and i cant switch DirectX12 off.. i personally think now its becouse of DirectX12 i get stutters.. also i get Coil Whine aswell..
 
Yes im getting packet loss..
But i managed to FIX stuttering for battlefield by switching DirectX12 OFF..
For NFS Heat i had to turn XMP on.. and solved 99% of the issues..
Phasmophobia & Roblox dont have any problems at all and never had.

the only game i have problems on right is Evil Dead The Game.. a lot of stuttering.. and i cant switch DirectX12 off.. i personally think now its becouse of DirectX12 i get stutters.. also i get Coil Whine aswell..
Yes, DX12 is no good for Battlefield.

Are you able to ping say Google without any loss?
 
Nov 23, 2022
22
0
10
0
Nov 23, 2022
22
0
10
0
Looks better! How's it working for you?
a little better.. Stutters.. sometimes..
Way more rare after XMP on and PSU Change..
nd disabling every startup apps.
I also reinstalled the drivers again.. (clean driver install) but still persists..
Tommorow im going to test Tom Clancy’s the Division 2 and see if its working corectly..
I really dont want to pump more money into my pc at this time.. hopefully i make it work..
Becouse i changed everything except RAM and MTB.

maybe rn its only that game that has stutters.. i dont have many games to test on sadly.. but ill do my best to test on some more tomorrow.

i really hope its something software sided 🥹
 
a little better.. Stutters.. sometimes..
Way more rare after XMP on and PSU Change..
nd disabling every startup apps.
I also reinstalled the drivers again.. (clean driver install) but still persists..
Tommorow im going to test Tom Clancy’s the Division 2 and see if its working corectly..
I really dont want to pump more money into my pc at this time.. hopefully i make it work..
Becouse i changed everything except RAM and MTB.

maybe rn its only that game that has stutters.. i dont have many games to test on sadly.. but ill do my best to test on some more tomorrow.

i really hope its something software sided 🥹
Clean off 20GB more space from the bx ssd and see if it helps.
 
Reactions: Zamfik267
Nov 23, 2022
22
0
10
0
Hello, so recently i’ve bought myself an RX 6650 XT 8gb Shappire Pulse, i had an RX 580..

But after installing the new gpu my pc was severely under performing.. i was getting wierd usages like 50% CPU 45% GPU in games but very low fps.. sometimes i would also get 100% GPU and 20% CPU or 100-80%CPU and 20% GPU.

in almost every game (low-med-high) graphics i get stuttering.. (on NFS Heat, Evil Dead, CSGO)

my rig
Ryzen 5 3400g
RX 6650 XT
Kingston Fury 16gb (2x8) 3200mHz RAM
600w PWS Bronze/Silver Certified
a320m s2h gigabyte motherboard
Crucial 256GB SSD
Gigabyte 255GB SSD
No Hard Drives.

this i’ve done to “reduce” my stuttering problems but kinda didnt work.

  • Clean GPU DRIVERS install using DDU.
  • installed Amd Chipsets.
  • optimised some windows settings
  • clean windows reinstall.
  • windows downgrade & upgrade.
  • checked if the GPU is installed correctly.
  • checked if the RAM was installed correctly.
  • benchmarked using FurMark and Userbenchmark.. (EVERYTHING WORKED FINE during benchmarks, no problems were found, worked fine)
Image links
View: https://imgur.com/a/aPUuKkw

View: https://imgur.com/a/GF6Yx2f
Also forgot to specify my mtb is PCIe 3.0 and my GPU is 4.0 could that be the problem?
 
Nov 23, 2022
22
0
10
0
Hello, so recently i’ve bought myself an RX 6650 XT 8gb Shappire Pulse, i had an RX 580..

But after installing the new gpu my pc was severely under performing.. i was getting wierd usages like 50% CPU 45% GPU in games but very low fps.. sometimes i would also get 100% GPU and 20% CPU or 100-80%CPU and 20% GPU.

in almost every game (low-med-high) graphics i get stuttering.. (on NFS Heat, Evil Dead, CSGO)

my rig
Ryzen 5 3400g
RX 6650 XT
Kingston Fury 16gb (2x8) 3200mHz RAM
600w PWS Bronze/Silver Certified
a320m s2h gigabyte motherboard
Crucial 256GB SSD
Gigabyte 255GB SSD
No Hard Drives.

this i’ve done to “reduce” my stuttering problems but kinda didnt work.

  • Clean GPU DRIVERS install using DDU.
  • installed Amd Chipsets.
  • optimised some windows settings
  • clean windows reinstall.
  • windows downgrade & upgrade.
  • checked if the GPU is installed correctly.
  • checked if the RAM was installed correctly.
  • benchmarked using FurMark and Userbenchmark.. (EVERYTHING WORKED FINE during benchmarks, no problems were found, worked fine)
Image links
View: https://imgur.com/a/aPUuKkw

View: https://imgur.com/a/GF6Yx2f
Update: stutters also present in Apex Legends.. but they are very very rare.. like 1 in 10 matches.. on very high settings.
 

ASK THE COMMUNITY