Question PC shuts down randomly when playing games.

Dec 20, 2020
23
0
10
0
My pc shuts down randomly when I'm playing games. I'm checking temps but my cpu and gpu are only at 60c and 65c. And when it shuts down, the monitor tries to get signal but it cant. Its just showing the hdmi on the monitor then a black screen. But when I unplug the pc and turn it on it goes back to normal. I hope I explained it clearly you can ask additional questions to me tho. What seems to be my problem here? Thank you!

Ryzen 5 2600
Rx 570 4gb
b450 mortar max
avexir core II 2x8gb
Cx550m
 

jay32267

Illustrious
My pc shuts down randomly when I'm playing games. I'm checking temps but my cpu and gpu are only at 60c and 65c. And when it shuts down, the monitor tries to get signal but it cant. Its just showing the hdmi on the monitor then a black screen. But when I unplug the pc and turn it on it goes back to normal. I hope I explained it clearly you can ask additional questions to me tho. What seems to be my problem here? Thank you!

Ryzen 5 2600
Rx 570 4gb
b450 mortar max
avexir core II 2x8gb
Cx550m
In the past when I've seen things similar to this it's usually either a bad power supply or bad ground and more often a bad power supply than a bad ground.
 
Dec 20, 2020
23
0
10
0
In the past when I've seen things similar to this it's usually either a bad power supply or bad ground and more often a bad power supply than a bad ground.
But
In the past when I've seen things similar to this it's usually either a bad power supply or bad ground and more often a bad power supply than a bad ground.
The monitor will show the video signal as hdmi then go black then show the signal again(it looks like its trying to reboot) then shuts down completely. Its not something that bothers me coz its not happening very often, but its good to know what is actually happening with my system right?
 

bmcmvox

Distinguished
Apr 23, 2013
19
1
18,515
0
Similar thing happened to me when I built my PC. Probably not the problem but check to make sure the motherboard/PSU cable is fully clicked into the motherboard and power supply. For me, one side of the connecter was not fully click in and my screen would go "no input", my peripherals would die and PC would become unresponsive under load forcing me to hard restart.
 
Reactions: ninthcloud
Dec 20, 2020
23
0
10
0
Similar thing happened to me when I built my PC. Probably not the problem but check to make sure the motherboard/PSU cable is fully clicked into the motherboard and power supply. For me, one side of the connecter was not fully click in and my screen would go "no input", my peripherals would die and PC would become unresponsive under load forcing me to hard restart.
That was the first thing I did. Thank you. I think uninstalling the drivers and reinstalling them fixed the problem. I played ac odyssey for 6hrs straight and no sign of flickering or random shutdowns. And my temps dropped down too. I dont know what happened but the first time I installed the latest adrenaline drivers my temps got to 70-73. but when I cleared it using ddu and installed it again, my gpu temps were 60 most of the time just like brandnew.
 

ASK THE COMMUNITY

TRENDING THREADS