Question PC shuts down randomly when using Mozilla, watching videos or when waking up from Sleep Mode ?

Nikos5

Distinguished
Nov 27, 2008
15
0
18,510
I have sort of a multi-layered problem. Dual Monitor Setup since 2009 - ATI Radeon HD 4800 Series

My WINDOWS 7 shuts off in a few different ways BY ITSELF. Often I try to watch Mozilla Videos the computer just abruptly Reboots by itself over and over again. When I put the computer in sleep mode then wake it up, it starts to work for a few seconds, but then the Monitors just abruptly go black and it states " Frequency Out of Range" then basically reboots the computer. I will often have to Restart 3 or 4 times just to be able to get back into Windows again and using the computer "semi-normally". When I use Chrome it seems to work normally, but I fear that at any moment the computer will just shut down and reboot. When I leave the PC and come back hours later, it seems to shut down by itself.

Could it possibly be a video card issue? A Mozilla/Flash issue? I do have a bunch of external hard drives and multiple hard drives, and tons of external USB items being used (multiple keyboard types, and mice, and external hard and USB drives etc...." also a webcam etc.... at times over the years I have always had trouble rebooting without some drivers occasionally not being recognized and not working until I restart the computer multiple times.

Could it be a driver issue? Malware? Combination of Flash Video/Monitor/Videocard/DRIVER overload issue? I am stumped as to what to do.

Any help would be greatly appreciated. I have had this problem for months now, and haven't had enough time to properly try and fix this (triple overtime at work). The computer is almost useless to use in the ways I typically need and use it. Mostly heavy web surfing dozens of tabs on Mozilla mostly, audio editing, heavy Music Listening, VLC Movie and and Audio, and Video Clips and Excel use.
 

Nikos5

Distinguished
Nov 27, 2008
15
0
18,510
After days of logging in and trying to use the computer, I am finally able to use Chrome with several browsers open etc...I can also use Mediamonkey Music player. I haven't tried Mozilla yet or any videos on my C Drive (which might trigger whatever is causing this dysfunction).

Does Chrome and Videos within chrome working essentially prove it isn't a video card issue?