Question Pc shuts down seconds/minutes after power button is pressed

Oct 3, 2020
5
0
10
0
As said it just randomly shuts down as the power button is pressed after 1-10 seconds anywhere in those times, sometimes I get lucky and it goes to 30-60 seconds but it even also sometimes don’t even let the power button work as it should( basically no power button and it’s just a button as a button with no purpose, yes the pc is still powered)

Pc specs
Ryzen 5 3600
Gigabyte 1660ti
ASUS Prime X570-P
2x Samsung Evo 960 500g
2x 2x8 C15 Corsair Vengeance
Thermaltake Smart 700W
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Have you tried powering the system while it's breadboarded? That PSU doesn't belong in the system. In fact, source a reliably built PSU and then try powering up the system.
 
Oct 3, 2020
5
0
10
0
Additional notes?

I though it was a faulty motherboard so I bought a new one which was the X570-P but then soon found out that it wasn’t the case. But after installing that X570 the pc was partially working?? I didn’t check for how long the pc was up for when it was fresh installed on first boot since I wanted 3000mhz speed since I thought it was fixed, but then after I changed the ram speeds from 2133 to 3000 that’s when the problem arose again. I changed it back miraculously but then nothing happened and now I’m here typing this out
 
Oct 3, 2020
5
0
10
0
Welcome to the forums, newcomer!

Have you tried powering the system while it's breadboarded? That PSU doesn't belong in the system. In fact, source a reliably built PSU and then try powering up the system.
Sorry but what is breadboarding? And I have also maybe confirmed that it is probably not the unreliable 700w psu either since I have a Corsair 500w and tried it with that and the same problem happened with the bare minimum amount of things plugged in. Unless they are both just happened to be faulty at the same time.
 
Oct 3, 2020
5
0
10
0
If anyone finds this before I have already bought my new pc here is some info,
Mobo is good
Ram is good
Gpu is good
Cpu is good
The two drives are good
Power supply is unsure, I don’t know how to check if it is actually good or bad on its own.
Me plugging it into a different outlet with a different cable seemed to boost the longevity of the timer before it shuts down to 1-30 minutes but it always shuts down immediately when I turn it on and then works on second try
 
Oct 3, 2020
5
0
10
0
If anyone does happen to even fall into this thread I have fixed it by changing the cooler from a Hyper 212 evo to my regular stock ryzen cooler and it’s working perfectly fine now... I don’t know how this is working but it is working perfectly fine
 

ASK THE COMMUNITY

TRENDING THREADS