[SOLVED] PC shuts off when starting up a modern game

ceriumin

Notable
Nov 13, 2018
442
51
940
28
As the title says I have been having this problem when trying to play modern games that I should be able to run.

My specs:
Radeon RX 580 Series
Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz
16 GB RAM
PSU SilverStone 700W SST-ST70F-PB

The latest game this happened with was https://store.steampowered.com/app/1344350/SUCCUBUS_Prologue/
Welcome to Toms Hardware @Ado13 !

Tried playing any other games with the same issue persisting? If it is the game only, try thoroughly checking temperatures and potentially wattage... because the PSU seems suspicious, however try stress testing your system to see if the issue persists. Could be the game itself as it states to be poorly optimised.
 

ceriumin

Notable
Nov 13, 2018
442
51
940
28
As the title says I have been having this problem when trying to play modern games that I should be able to run.

My specs:
Radeon RX 580 Series
Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz
16 GB RAM
PSU SilverStone 700W SST-ST70F-PB

The latest game this happened with was https://store.steampowered.com/app/1344350/SUCCUBUS_Prologue/
Welcome to Toms Hardware @Ado13 !

Tried playing any other games with the same issue persisting? If it is the game only, try thoroughly checking temperatures and potentially wattage... because the PSU seems suspicious, however try stress testing your system to see if the issue persists. Could be the game itself as it states to be poorly optimised.
 
Jul 25, 2020
4
0
10
0
Welcome to Toms Hardware @Ado13 !

Tried playing any other games with the same issue persisting? If it is the game only, try thoroughly checking temperatures and potentially wattage... because the PSU seems suspicious, however try stress testing your system to see if the issue persists. Could be the game itself as it states to be poorly optimised.
Ye it happens with a few other games I tried. Games that have more demanding system requirements, while all the older games run fine without such problems. I was worried that it may be my GPU overheating or something, but this happens even with the GPU temperature staying below 70°C.
 

ceriumin

Notable
Nov 13, 2018
442
51
940
28
Ye it happens with a few other games I tried. Games that have more demanding system requirements, while all the older games run fine without such problems. I was worried that it may be my GPU overheating or something, but this happens even with the GPU temperature staying below 70°C.
I had this issue once as well which I forgot to mention, but try stress testing your computer under load, temperatures as well such as your CPU. Try using cinebench and check if your pc shuts off. Record the temps and see at what cpu temperature your CPU is once your pc shuts off, if it does at all. If it goes fine without issues, do the same in game and wait for the issue to persist, and once it does, tell me the temperature of the CPU. Does your computer not shut itself off completely but rather the monitor and peripherals?
 
Reactions: Ado13
Jul 25, 2020
4
0
10
0
Ok I tried running the game again while paying close attention to the temperatures. CPU temperature was at 53°C and GPU was at 73°C when it shot down. And yes it's a complete shot down like when I turn it off myself.
However, a different problem appeared now as well. When I tried to turn it on again, the monitor didn't show anything. I had to restart the PC a few times for it finally start working. The lamp at the power button was glowing blue at both sides in the times when nothing appear on the monitor, and after the few restarts it was blinking red on the left side like this in the time that it turned on properly. https://cdn.discordapp.com/attachments/578526669288112130/737002126374600785/20200726_193643.jpg The lamp blinking red is how it is usually when I turn it on.

Edit:
Did a stress test with HeavyLoad. The CPU temperature was mostly stable at 53°C and no crashes happened.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS